Fun In B.C.  

Welcome to the Fun In B.C. forums. your outdoor adventure headquarters.

As guest on our site, you have the chance to take a look around and get an idea of what we're all about. Feel free to check out some of the current topics of discussion and some of the stories of adventure gone by, by clicking on the top right picture to view past "Pictures of the week" .

Don't be shy, come on in. By joining our free community you'll be able to join in the fun with other outdoor adventurers and find out about upcoming events. you will also get access to View posted pictures. Stop sitting on the outside looking in, join today it's easy and it's FREE.

It's time for you to start having FUN..... in BC!!

If you have any problems with the registration process or your account login, please contact contact support.

HOTMAIL USERS: Check your 'junk mail' folder for the confirmation message and add 'funinbc.com' to your safe list so you don't miss anymore important emails from us.

Go Back   Fun In B.C. > All about your Ride > suzuki Talk

Reply
 
Thread Tools
  #1  
Old 06-09-2007, 08:41 PM
beeker beeker is offline
Gettin' out havin' fun
 
Join Date: Nov 2004
Location: abby, Canary Islands.
Posts: 463
beeker bad newbie
Reputation: 0
??????

hey i got a 91 sami 1.3 FI problem im having is it wont stay running longer than 30 seconds it will start ,run, then die! then it wont refire. just turns over and over. ive replaces the fuel filter and spark module (ignition box) with no change anyone else know of this problem or a solution to it????
Reply With Quote
  #2  
Old 06-09-2007, 11:44 PM
ray ray is offline
Having FUN IN B.C.
 
Join Date: Apr 2006
Location: abbotsford
Posts: 892
ray Good newbie
Reputation: 11
distributor cap aand rotor? spark plugs wires ?

ignition module
__________________

your not 4X4ING if your not brakin stuff
Reply With Quote
  #3  
Old 06-10-2007, 02:28 AM
HillBillyLincoln HillBillyLincoln is offline
Prospect
 
Join Date: Sep 2006
Location: abbotsford
Posts: 235
HillBillyLincoln Unknown Newbie
Reputation: 10
coil?? fuel pump relay?
__________________
Jesus is coming....Look busy!
Reply With Quote
  #4  
Old 06-14-2007, 09:28 AM
Chillbilly Chillbilly is offline
Newbie
 
Join Date: Jun 2007
Location: Chilliwack BC Canada
Posts: 12
Chillbilly Unknown Newbie
Reputation: 10
you should do the diagnostic test thing with the fuse box....never had a 91 but i think there is a fuse in the fuse box you can stick in then turn the key.....the gauges will blink with a code for ya that you can find in the manual.

Mine didnt have that option..maybe someone on here knows what im talkin about and can elaberate by the way..nice zuki beeker
Reply With Quote
  #5  
Old 06-14-2007, 09:48 AM
ShortStack's Avatar
ShortStack ShortStack is offline
 
Join Date: Sep 2004
Location: Ridge
Posts: 2,449
ShortStack bad newbie
Reputation: 0
On the rabbits sometimes (when the came out) the starter relay would over heat and cause that sort of prob there was an upgrade for it.

my car had similar probs to yours and it was the fuel pump relay. But it'd mostly die while driving it but when it died out it wouldn't start for a few tries/minutes. You can jump the fuel pump relay and see if it'll stay running. Can you hear it cycle when you turn the key?

Gotta give more details about what its doing when its running or how it dies etc. does it run after you let go of the key? Smell, smoke, sounds etc What were other recent repairs you did to it? Have you removed the coil wires?
__________________
`77 K5 Blazer - Big, Black, BROKE, Ugly But All Mine

Its Lifted ... and Fat Chicks CAN Climb.
Reply With Quote
  #6  
Old 06-14-2007, 12:36 PM
norm norm is offline
nout to do with me
 
Join Date: Mar 2005
Location: lake country, bc, Canada.
Posts: 1,103
norm bad newbie
Reputation: 0
I assume it's EFI,put a fuel pressure guage on it.Prolly delivers enuf pressure
to start and then drops below what u need.Even if u can hear pump run or
it sprays out the hose it may not be enuf to feed injector(40 psi'sh)
__________________
I brake for bungee's
Reply With Quote
  #7  
Old 06-14-2007, 04:19 PM
Zukbuilder Zukbuilder is offline
Not a Newbie
 
Join Date: Apr 2005
Location: Surrey, BC, Canada.
Posts: 641
Zukbuilder bad newbie
Reputation: 0
Wayne,

Sell that piece of shit !!
Reply With Quote
  #8  
Old 06-14-2007, 05:12 PM
redwingfan_number19 redwingfan_number19 is offline
Now I see what FIBC is about
 
Join Date: Nov 2003
Location: Chilliwack, BC, Canada.
Posts: 168
redwingfan_number19 bad newbie
Reputation: 0
dude, give me a call, my buddy will look at it, really wants to make a deal for the floors,

Later

Matt
__________________
91 Toyota P/U x-cab, stuff, 1972 Toyota Celica
1994 f-250 tow rig
Reply With Quote
  #9  
Old 06-15-2007, 12:46 PM
rs9000 rs9000 is offline
Prospect
 
Join Date: Jan 2006
Location: Maple ridge
Posts: 277
rs9000 Unknown Newbie
Reputation: 10
fule preesure

Quote:
Originally Posted by norm View Post
I assume it's EFI,put a fuel pressure guage on it.Prolly delivers enuf pressure
to start and then drops below what u need.Even if u can hear pump run or
it sprays out the hose it may not be enuf to feed injector(40 psi'sh)
im actually having the same problm as beaker i read throught my maunal u need 3-10 psi for ur fule injejtion for it to work properly. i need to get mine hook up to a diganostics thing ive all ready take out my injecter and fule filter still not running right dunno wat im going to do ethere beeker pm me about this let me know wat u have trouble shot and ill let u know wat ive done
__________________
1986 22re 5spd sas'd new motor 35's front locker
Reply With Quote
  #10  
Old 06-16-2007, 08:22 PM
beeker beeker is offline
Gettin' out havin' fun
 
Join Date: Nov 2004
Location: abby, Canary Islands.
Posts: 463
beeker bad newbie
Reputation: 0
ive done a fair bit r/r fuel filter ,both relays , ignition module pulled off dist wire and ground with spark testor NO SPARK pulled the computer found bad diode/cap replaced it with same one (NEW) and rehooked up still no spark pulled it back out and drank a few beers!! havent tried a coil yet as nobody i know has one i can swap with to test i know it gets fuel i can smell it all it does is turn over and over!!!!
Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Style Design By: Resourcelabz.se