Fun In B.C.  

Welcome to the Fun In B.C. forums. your outdoor adventure headquarters.

As guest on our site, you have the chance to take a look around and get an idea of what we're all about. Feel free to check out some of the current topics of discussion and some of the stories of adventure gone by, by clicking on the top right picture to view past "Pictures of the week" .

Don't be shy, come on in. By joining our free community you'll be able to join in the fun with other outdoor adventurers and find out about upcoming events. you will also get access to View posted pictures. Stop sitting on the outside looking in, join today it's easy and it's FREE.

It's time for you to start having FUN..... in BC!!

If you have any problems with the registration process or your account login, please contact contact support.

HOTMAIL USERS: Check your 'junk mail' folder for the confirmation message and add 'funinbc.com' to your safe list so you don't miss anymore important emails from us.

Go Back   Fun In B.C. > All about your Ride > suzuki Talk

Reply
 
Thread Tools
  #1  
Old 04-12-2007, 04:44 PM
jesslee jesslee is offline
Prospect
 
Join Date: Apr 2006
Location: Kelowna
Posts: 234
jesslee Unknown Newbie
Reputation: 10
window wiper issues??

okay my wipers arent working and its kinda a pin in the ass trying to squeegee my windows when it rains and i have to drive at the same time. checked the fuse of course it was fine. looked at the wiper motor, but i really have NO idea AT ALL about anything electrical such as wireing or this little motor thing, so if theres a way to check if the motor is just fried or if some wires are just fucked, some knowledge would help me tons! They just kinda stopped working one day no reason, just stopped... if that helps any, thats all the info ive got??? help me pleeease
__________________
Suzuki Samurai owner.
Reply With Quote
  #2  
Old 04-12-2007, 04:46 PM
jesslee jesslee is offline
Prospect
 
Join Date: Apr 2006
Location: Kelowna
Posts: 234
jesslee Unknown Newbie
Reputation: 10
and if i turn on my wipers to the first click... it makes weird turning signal noise but all random and fucked sounding comeing from the dash... and if i click it past the fist one it's just silent.. nothing.
__________________
Suzuki Samurai owner.
Reply With Quote
  #3  
Old 04-12-2007, 06:39 PM
zookiguy zookiguy is offline
Not a Newbie
Swollen Member
 
Join Date: Jun 2004
Location: Abbotsford.
Posts: 688
zookiguy bad newbie
Reputation: 0
check to make sure your window frame is grounded probably. Just take a wire and ground it from the motor to the neg post on the battery. If it works thats the problem, if not you need a new motor.

There not cheap for a rebuilt. But I might have a used one here somewhere.
Reply With Quote
  #4  
Old 04-12-2007, 06:51 PM
sj-x 500's Avatar
sj-x 500 sj-x 500 is offline
das Zukenstein
 
Join Date: Apr 2003
Location: vernon, bc, Canada.
Posts: 3,396
sj-x 500 bad newbie
Reputation: 0
you just gotta get your self a squeegee kid.
squegee kid.jpg
ham squeegee.jpg
Reply With Quote
  #5  
Old 04-12-2007, 08:43 PM
jesslee jesslee is offline
Prospect
 
Join Date: Apr 2006
Location: Kelowna
Posts: 234
jesslee Unknown Newbie
Reputation: 10
haha man thats pretty much what i had going last time i was out it was POURING rain/snow... my brother was my squeegee boy.. alright i'll check out the greound issue on saturday when i got some time... if thats the problem that would be pretty damn simple.. (fingers crossed) thank yous
__________________
Suzuki Samurai owner.
Reply With Quote
  #6  
Old 04-12-2007, 09:05 PM
sj-x 500's Avatar
sj-x 500 sj-x 500 is offline
das Zukenstein
 
Join Date: Apr 2003
Location: vernon, bc, Canada.
Posts: 3,396
sj-x 500 bad newbie
Reputation: 0
it could be the switch too though, hard to tell you how to test it on here, but backprobe the connetor at the wiper motor, you need to have power on all 3 settings
Reply With Quote
  #7  
Old 04-13-2007, 01:08 AM
epic3's Avatar
epic3 epic3 is offline
cornbinder on coils
Swollen Member
 
Join Date: Dec 2004
Location: Richmond, Canada.
Posts: 13,710
epic3 bad newbie
Reputation: 2
burn it
__________________
founding member of A.A.
Reply With Quote
  #8  
Old 04-13-2007, 10:30 AM
ray ray is offline
Having FUN IN B.C.
 
Join Date: Apr 2006
Location: abbotsford
Posts: 892
ray Good newbie
Reputation: 11
or epic could get a suzuki so he can burn it himself...............
__________________

your not 4X4ING if your not brakin stuff
Reply With Quote
  #9  
Old 04-15-2007, 07:19 PM
jesslee jesslee is offline
Prospect
 
Join Date: Apr 2006
Location: Kelowna
Posts: 234
jesslee Unknown Newbie
Reputation: 10
hey zookieguy i tried the ground wire thing... it made the clicking on the first setting go alot faster... but that was about it, pretty sure the thing is f.u.b.a.r , how much you want for the used one if youve got it??
__________________
Suzuki Samurai owner.
Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Style Design By: Resourcelabz.se