Fun In B.C.  

Welcome to the Fun In B.C. forums. your outdoor adventure headquarters.

As guest on our site, you have the chance to take a look around and get an idea of what we're all about. Feel free to check out some of the current topics of discussion and some of the stories of adventure gone by, by clicking on the top right picture to view past "Pictures of the week" .

Don't be shy, come on in. By joining our free community you'll be able to join in the fun with other outdoor adventurers and find out about upcoming events. you will also get access to View posted pictures. Stop sitting on the outside looking in, join today it's easy and it's FREE.

It's time for you to start having FUN..... in BC!!

If you have any problems with the registration process or your account login, please contact contact support.

HOTMAIL USERS: Check your 'junk mail' folder for the confirmation message and add 'funinbc.com' to your safe list so you don't miss anymore important emails from us.

Go Back   Fun In B.C. > All about your Ride > Chevy ramblings

Reply
 
Thread Tools
  #1  
Old 11-26-2013, 09:06 PM
longhorn's Avatar
longhorn longhorn is offline
Long where it counts
Swollen Member
 
Join Date: Sep 2004
Location: WL
Posts: 2,012
longhorn bad newbie
Reputation: 2
Chev junk

Ive got a 2000 Chev 1 ton with a 454 I use for a service /tool truck.
It usually goes and runs OK everyday but lately its giving me some issues.
I leave it out west at a job site.

Every morning when we start it up it gets hot, guage goes right over.
Shut it off and leave it for 10 minutes and its Ok.

Its like something is freezing (its been -10 and colder) and after it gets hot it thaws out.
Its good all the rest of the day but will get hot again tomorrow morning.

Its got lots of antifreeze , a 6 month old rad and a waterpump in the last year.

Any ideas?
Reply With Quote
  #2  
Old 11-26-2013, 10:37 PM
4skin's Avatar
4skin 4skin is offline
Cact
Swollen Member
 
Join Date: Feb 2010
Posts: 8,694
4skin Good newbie
Reputation: 15
Sticky thermostat maybe test the anti freeze with a hydrometer
Might look green but not for low enough temp
I did it grabbed premix by mistake and mixed it 50 50
Started overheating on way to Prince George rad was freezing on hiway stop and it would thaw out figured it out after putting cardboard over grill and blocked
The cold air it quit over heating was only good to -15 when we tested it
Reply With Quote
  #3  
Old 11-27-2013, 06:11 PM
85chevy 85chevy is offline
Nothing Runs Like a Deere
 
Join Date: Feb 2009
Location: Langley, BC
Posts: 2,471
85chevy Good newbie
Reputation: 12
Yup what Bruce said that is the only thing that would make sense if its fine after
__________________
1992 Jeep Cherokee
1985 Chevy 4x4
Reply With Quote
  #4  
Old 11-27-2013, 07:49 PM
longhorn's Avatar
longhorn longhorn is offline
Long where it counts
Swollen Member
 
Join Date: Sep 2004
Location: WL
Posts: 2,012
longhorn bad newbie
Reputation: 2
I started it up this morning and it heated right up. I drove it 1 km to job site and shut it off.
Got in it tonight and drove it 50 kms, everything worked good.
Lots of heat coming out of heater and guage was only up 1/4 way.
Ill change thermostat soon as I get it home.
Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Style Design By: Resourcelabz.se