Fun In B.C.  

Welcome to the Fun In B.C. forums. your outdoor adventure headquarters.

As guest on our site, you have the chance to take a look around and get an idea of what we're all about. Feel free to check out some of the current topics of discussion and some of the stories of adventure gone by, by clicking on the top right picture to view past "Pictures of the week" .

Don't be shy, come on in. By joining our free community you'll be able to join in the fun with other outdoor adventurers and find out about upcoming events. you will also get access to View posted pictures. Stop sitting on the outside looking in, join today it's easy and it's FREE.

It's time for you to start having FUN..... in BC!!

If you have any problems with the registration process or your account login, please contact contact support.

HOTMAIL USERS: Check your 'junk mail' folder for the confirmation message and add 'funinbc.com' to your safe list so you don't miss anymore important emails from us.

Go Back   Fun In B.C. > All about your Ride > suzuki Talk

Reply
 
Thread Tools
  #1  
Old 02-19-2013, 11:11 AM
deetguy deetguy is offline
Newbie
 
Join Date: Feb 2013
Posts: 2
deetguy Good newbie
Reputation: 11
staling problem

have an 07 king quad...that stalls when rpm comes down to an idle...worse when its hot out.....can restart and ride right away...but keeps happening when slowing down...have had it in the shop on 3 occasions...they say they can't find the problem somebody else must have had this problem before or did i win the wrong lottery.... heeeeeeeeeeelp
Reply With Quote
  #2  
Old 02-19-2013, 02:27 PM
toyon35s toyon35s is offline
rollin a chev on 40's now bitches
 
Join Date: Mar 2007
Location: surrey
Posts: 1,953
toyon35s Good newbie
Reputation: 11
mine did the same ,ecu problem ,get it flashed and it should be good to go
__________________
hookers and blow
Reply With Quote
  #3  
Old 02-20-2013, 11:04 AM
deetguy deetguy is offline
Newbie
 
Join Date: Feb 2013
Posts: 2
deetguy Good newbie
Reputation: 11
ecu

where to go to it flashed?
Reply With Quote
  #4  
Old 02-20-2013, 07:20 PM
85chevy 85chevy is offline
Nothing Runs Like a Deere
 
Join Date: Feb 2009
Location: Langley, BC
Posts: 2,471
85chevy Good newbie
Reputation: 12
dealership I would imagine
__________________
1992 Jeep Cherokee
1985 Chevy 4x4
Reply With Quote
  #5  
Old 02-20-2013, 08:00 PM
godtool godtool is offline
Nothin' but a post whore
 
Join Date: Oct 2004
Location: Forest Grove (100 Mile House)
Posts: 932
godtool bad newbie
Reputation: 0
coil getting hot and stops working at idle??
__________________
81 Jimmy, 4" Lift, 38" TSL's, 14 Bolt\Detroit, Dana 60
My site: wwwCariboo4x4ca
Reply With Quote
  #6  
Old 02-20-2013, 11:42 PM
4skin's Avatar
4skin 4skin is offline
Cact
Swollen Member
 
Join Date: Feb 2010
Posts: 8,689
4skin Good newbie
Reputation: 15
Someone on here is a quad repair guy
Can't think of who though
Reply With Quote
  #7  
Old 02-21-2013, 08:47 AM
bigorange440 bigorange440 is offline
Prospect
 
Join Date: Sep 2005
Location: abbotsford, bc, Canada.
Posts: 288
bigorange440 bad newbie
Reputation: 1
check the fuel pressure. super super common problem with the king quads for the fuel pumps to get low pressure. if it is weak dont go oem. the ford pump works with very minor mods and will last way longer.
__________________
jeep yj 7 inch lift 33 inch swampers. 488 gears detroit lockers front and rear, warn winch, bumpers and so on and a 79 mustang on 44s
Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Style Design By: Resourcelabz.se