Fun In B.C.  

Welcome to the Fun In B.C. forums. your outdoor adventure headquarters.

As guest on our site, you have the chance to take a look around and get an idea of what we're all about. Feel free to check out some of the current topics of discussion and some of the stories of adventure gone by, by clicking on the top right picture to view past "Pictures of the week" .

Don't be shy, come on in. By joining our free community you'll be able to join in the fun with other outdoor adventurers and find out about upcoming events. you will also get access to View posted pictures. Stop sitting on the outside looking in, join today it's easy and it's FREE.

It's time for you to start having FUN..... in BC!!

If you have any problems with the registration process or your account login, please contact contact support.

HOTMAIL USERS: Check your 'junk mail' folder for the confirmation message and add 'funinbc.com' to your safe list so you don't miss anymore important emails from us.

Go Back   Fun In B.C. > All about your Ride > Jeep Talk

Jeep Talk The only true 4x4

Reply
 
Thread Tools
  #1  
Old 12-04-2011, 09:56 PM
Hellboy Hellboy is offline
iEdited my Title in 'User CP'
 
Join Date: May 2011
Location: Coquitlam
Posts: 1,133
Hellboy Unknown Newbie
Reputation: 10
Exclamation 4.0L missing

So my Aunts 4.0L cherokee is misfiring and she wants me to come check it out. Anyhow I'm hoping it's simple stuff like a bad plug or shitty cap. However, if its not the regular stuff (plugs cap rotor wires), just wondering what else it could be if anything?

Thought I'd put that out there since I have to go out there after work tomorrow as she doesn't have a car now.

Its a newer one 96 or higher And automatic

__________________
Reply With Quote
  #2  
Old 12-04-2011, 10:07 PM
crazylike crazylike is offline
Make your own-iEdit Title in 'User CP'
 
Join Date: Apr 2007
Location: Westbank
Posts: 1,372
crazylike bad newbie
Reputation: 8
plugs , wires , coil , fuel filter , vacuum leaks , incorrect idle , incorrect ignition timing , low or uneven cylinder compression , choke , clogged or dirty injector , cracked distributor , leaky egr valve. these are what the books says for engine misses
__________________
2015 Ram 1500 with 2 inch lift
Reply With Quote
  #3  
Old 12-04-2011, 10:10 PM
Hellboy Hellboy is offline
iEdited my Title in 'User CP'
 
Join Date: May 2011
Location: Coquitlam
Posts: 1,133
Hellboy Unknown Newbie
Reputation: 10
Ya i wish i had a compression tester cuz thats easy too...
__________________
Reply With Quote
  #4  
Old 12-05-2011, 05:38 PM
Happypants's Avatar
Happypants Happypants is offline
Rollin like a redneck
Swollen Member
 
Join Date: Nov 2006
Posts: 11,503
Happypants Good newbie
Reputation: 12
Check the main stuff first, cap,rotor,plugs,wires, if there is any yellow corrosion on the points or anything they need to e
Replaced, also check the top of the cap, it could be
Cracked or possibly melted, I've melted a cap before, if that's all good it could be a fuel filter or a number of other things, CPS,TPS,iac, doubt it's inside the motor, most likely a sensor
__________________
Quote:
Originally Posted by pudge
try to keep up spongebob, you're sucking his dick, whilest Mrs Tuna jams herself and Jerm watches
Reply With Quote
  #5  
Old 12-05-2011, 09:07 PM
Hellboy Hellboy is offline
iEdited my Title in 'User CP'
 
Join Date: May 2011
Location: Coquitlam
Posts: 1,133
Hellboy Unknown Newbie
Reputation: 10
Quote:
Originally Posted by Happypants View Post
Check the main stuff first, cap,rotor,plugs,wires, if there is any yellow corrosion on the points or anything they need to e
Replaced, also check the top of the cap, it could be
Cracked or possibly melted, I've melted a cap before, if that's all good it could be a fuel filter or a number of other things, CPS,TPS,iac, doubt it's inside the motor, most likely a sensor
ok so its a 2001 and theres definately no cap or rotor. plugs are brand new.

Only fuel filter on a 2001 cherokee is in the gas tank according to crappy tire, and I couldn't see one in the open anywhere...

I think it might be the thing your truck was doing nick, cause I drove it a bit and it would run fine... then engine light would flash and it would stutter and surge, almost like it would die... I had to pop into neutral and rev it, then back to drive...
__________________
Reply With Quote
  #6  
Old 12-05-2011, 09:16 PM
B's Avatar
B B is offline
FUCK CANCER
Swollen Member
 
Join Date: Jan 2005
Location: The Ridge, communist, Russia.
Posts: 5,105
B bad newbie
Reputation: 5
If the engine light triggered u have a stored code scan and repair or keep guessing and replacing needlessly
__________________

Originally Posted by Happypants
do you want this thread deleted?
Reply With Quote
  #7  
Old 12-05-2011, 09:25 PM
Hellboy Hellboy is offline
iEdited my Title in 'User CP'
 
Join Date: May 2011
Location: Coquitlam
Posts: 1,133
Hellboy Unknown Newbie
Reputation: 10
Quote:
Originally Posted by B View Post
If the engine light triggered u have a stored code scan and repair or keep guessing and replacing needlessly
scanned and it said 'cylinder misfired'

reset the comp and 2 weeks later it did it again...

now its running rough

and we havent replaced anything yet...
__________________
Reply With Quote
  #8  
Old 12-06-2011, 07:54 AM
crazylike crazylike is offline
Make your own-iEdit Title in 'User CP'
 
Join Date: Apr 2007
Location: Westbank
Posts: 1,372
crazylike bad newbie
Reputation: 8
i would venture a guess and say bad/plugged injector or burned out plug on cylinder 2..
__________________
2015 Ram 1500 with 2 inch lift
Reply With Quote
  #9  
Old 12-06-2011, 10:17 AM
Hellboy Hellboy is offline
iEdited my Title in 'User CP'
 
Join Date: May 2011
Location: Coquitlam
Posts: 1,133
Hellboy Unknown Newbie
Reputation: 10
Quote:
Originally Posted by crazylike View Post
i would venture a guess and say bad/plugged injector or burned out plug on cylinder 2..
Why cylinder 2..?
__________________
Reply With Quote
  #10  
Old 12-06-2011, 10:42 AM
crazylike crazylike is offline
Make your own-iEdit Title in 'User CP'
 
Join Date: Apr 2007
Location: Westbank
Posts: 1,372
crazylike bad newbie
Reputation: 8
i had a 4.0 and i had many issues similar to this and it was the number 2 injector multiple times. just thinking since it sounds so much the same you might wanna try looking there first. i just noticed you said new plugs have been installed so i would say injector or maybe even the coil.
__________________
2015 Ram 1500 with 2 inch lift
Reply With Quote
  #11  
Old 12-13-2011, 01:15 AM
Hellboy Hellboy is offline
iEdited my Title in 'User CP'
 
Join Date: May 2011
Location: Coquitlam
Posts: 1,133
Hellboy Unknown Newbie
Reputation: 10
Quote:
Originally Posted by crazylike View Post
i had a 4.0 and i had many issues similar to this and it was the number 2 injector multiple times. just thinking since it sounds so much the same you might wanna try looking there first. i just noticed you said new plugs have been installed so i would say injector or maybe even the coil.
so guess what...

it was the number 2 injector

coincidence i guess
__________________
Reply With Quote
  #12  
Old 12-13-2011, 08:27 AM
crazylike crazylike is offline
Make your own-iEdit Title in 'User CP'
 
Join Date: Apr 2007
Location: Westbank
Posts: 1,372
crazylike bad newbie
Reputation: 8
holy shit i'm good
__________________
2015 Ram 1500 with 2 inch lift
Reply With Quote
  #13  
Old 12-13-2011, 01:54 PM
BleepinJeep BleepinJeep is offline
Having FUN IN B.C.
 
Join Date: May 2011
Location: Great White North
Posts: 811
BleepinJeep Good newbie
Reputation: 11
Nice work (stands and gives applause)
__________________
Reply With Quote
  #14  
Old 12-13-2011, 02:34 PM
Hellboy Hellboy is offline
iEdited my Title in 'User CP'
 
Join Date: May 2011
Location: Coquitlam
Posts: 1,133
Hellboy Unknown Newbie
Reputation: 10
Quote:
Originally Posted by BleepinJeep View Post
Nice work (stands and gives applause)
__________________
Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Style Design By: Resourcelabz.se