Fun In B.C.  

Welcome to the Fun In B.C. forums. your outdoor adventure headquarters.

As guest on our site, you have the chance to take a look around and get an idea of what we're all about. Feel free to check out some of the current topics of discussion and some of the stories of adventure gone by, by clicking on the top right picture to view past "Pictures of the week" .

Don't be shy, come on in. By joining our free community you'll be able to join in the fun with other outdoor adventurers and find out about upcoming events. you will also get access to View posted pictures. Stop sitting on the outside looking in, join today it's easy and it's FREE.

It's time for you to start having FUN..... in BC!!

If you have any problems with the registration process or your account login, please contact contact support.

HOTMAIL USERS: Check your 'junk mail' folder for the confirmation message and add 'funinbc.com' to your safe list so you don't miss anymore important emails from us.

Go Back   Fun In B.C. > All about your Ride > Ford discussions

Reply
 
Thread Tools
  #1  
Old 05-24-2011, 01:24 PM
deer laredo deer laredo is offline
Prospect
 
Join Date: Oct 2006
Location: mission bc
Posts: 214
deer laredo Unknown Newbie
Reputation: 10
c6 2wd

looking for some help with a 2wd c6, i put th tourque co verter in wrong started it made noise so i took it out and put it in right now i cant get it to pump... any ideas or reuild the hole thing?
Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Style Design By: Resourcelabz.se