Fun In B.C.  

Welcome to the Fun In B.C. forums. your outdoor adventure headquarters.

As guest on our site, you have the chance to take a look around and get an idea of what we're all about. Feel free to check out some of the current topics of discussion and some of the stories of adventure gone by, by clicking on the top right picture to view past "Pictures of the week" .

Don't be shy, come on in. By joining our free community you'll be able to join in the fun with other outdoor adventurers and find out about upcoming events. you will also get access to View posted pictures. Stop sitting on the outside looking in, join today it's easy and it's FREE.

It's time for you to start having FUN..... in BC!!

If you have any problems with the registration process or your account login, please contact contact support.

HOTMAIL USERS: Check your 'junk mail' folder for the confirmation message and add 'funinbc.com' to your safe list so you don't miss anymore important emails from us.

Go Back   Fun In B.C. > All about your Ride > Dodge Talk

Reply
 
Thread Tools
  #1  
Old 01-30-2010, 11:20 PM
crazylike crazylike is offline
Make your own-iEdit Title in 'User CP'
 
Join Date: Apr 2007
Location: Westbank
Posts: 1,372
crazylike bad newbie
Reputation: 8
weird fuel issue

my ram charger is building up pressure in the gas tank... the truck stalls after a trip from my place on westside into the mall then down to knox mountain and back to westside the truck starts lurching and then stalls i undid the gas cap and it made the vacuum noise... then i jumped in turned the key it fired right up.. but the other day i started it up it ran for like 1 minute then stalled it would turn over real good but no fire i went and got 20 in gas and when i went to dump the 20 bucks in fuel in i noticed the gas cap was not done up... so i dumped in the 20 and did up the cap then had this issue today.. i really doubt i used 20 in fuel doing that little trip.... any ideas would be great.... as i am running low....
Reply With Quote
  #2  
Old 01-31-2010, 12:25 AM
Explorer guy418 Explorer guy418 is offline
Austin Roy Crutch
 
Join Date: Jul 2004
Location: Kelowna B.C.
Posts: 3,060
Explorer guy418 bad newbie
Reputation: 2
well id start by getting a new gas cap.
__________________
Reply With Quote
  #3  
Old 01-31-2010, 01:04 AM
Maelthra Maelthra is offline
Not a Newbie
 
Join Date: Sep 2006
Location: Hope
Posts: 696
Maelthra bad newbie
Reputation: 9
gas tank vent?
__________________
[1983 Dodge W350][360, 315/75R16s, 6" lift]
[1992 Dodge W250][CTD - Auto - stock as stock is]
Reply With Quote
  #4  
Old 02-03-2010, 07:57 AM
crazylike crazylike is offline
Make your own-iEdit Title in 'User CP'
 
Join Date: Apr 2007
Location: Westbank
Posts: 1,372
crazylike bad newbie
Reputation: 8
so i changed the fuel cap no better no worse.... i dumped 50 bucks in fuel in the tank but it still is over pressurizing. i havn't been able to track down the gas tank vent i think its on top the tank and i really dont wanna drop the tank... i gonna try pressure washing the top of tank as there was lots of mud under the truck... i'll keep ya posted and if anyone has anymore ideas please post em...
Reply With Quote
  #5  
Old 02-03-2010, 07:32 PM
Trooper Trooper is offline
Fisting for dollars
 
Join Date: Aug 2005
Location: Vancouver, Canada.
Posts: 1,543
Trooper bad newbie
Reputation: 1
hows it run with the gas cap off?
__________________

Taint nothin'
Reply With Quote
  #6  
Old 02-03-2010, 09:15 PM
crazylike crazylike is offline
Make your own-iEdit Title in 'User CP'
 
Join Date: Apr 2007
Location: Westbank
Posts: 1,372
crazylike bad newbie
Reputation: 8
with the cap right off it refuses to run at all.. with the cap loose it runs ok but has a small miss....
Reply With Quote
  #7  
Old 03-18-2010, 12:33 AM
Styx Styx is offline
Having FUN IN B.C.
 
Join Date: Jan 2006
Location: In the Corn
Posts: 713
Styx Unknown Newbie
Reputation: 10
What year is it???
And what engine and all that stuff...
__________________
Who would have thunked it???
Reply With Quote
  #8  
Old 03-18-2010, 08:41 AM
crazylike crazylike is offline
Make your own-iEdit Title in 'User CP'
 
Join Date: Apr 2007
Location: Westbank
Posts: 1,372
crazylike bad newbie
Reputation: 8
its a 90 with a 360 and a od tranny and a 241 t-case
Reply With Quote
  #9  
Old 03-18-2010, 09:18 AM
Styx Styx is offline
Having FUN IN B.C.
 
Join Date: Jan 2006
Location: In the Corn
Posts: 713
Styx Unknown Newbie
Reputation: 10
What's your fuel pressure at???
You may have a week pump...
CFI injection needs something like 40 psi and good volume, multi-point needs up around 60 and even more volume... Even if the pressure is ok check the volume I have had them make enough pressure and they still don't run after they warm up or are driven for a bit...
My dealer connect account won't go back to 90 to check the specks and I don't make it into the shop much anymore to check the books but get me some pressures and flow rates and we can figure out if it's enough...
PM me the last 8 of your vin and I will run it just in case...
__________________
Who would have thunked it???
Reply With Quote
  #10  
Old 03-18-2010, 09:51 AM
crazylike crazylike is offline
Make your own-iEdit Title in 'User CP'
 
Join Date: Apr 2007
Location: Westbank
Posts: 1,372
crazylike bad newbie
Reputation: 8
i havn't checked the pressure at the back of the TBI unit.
i assumed since the pressure in the tank is causing a suction in the tank it must be sucking hard enuf ..
i have been running it around with the cap loose and it seems to go ok i just filled it to the top and now i have figured that when it starts to dip below the F mark its time to feed it another 100 .
the book says the pressure should be 14-15 psi with regulator vacuum hose attached and 18-20 with it disconnected.
i dont have the tool needed to do this test.
Reply With Quote
  #11  
Old 07-07-2010, 12:45 PM
Meeshies's Avatar
Meeshies Meeshies is offline
Having FUN IN B.C.
 
Join Date: Nov 2009
Location: Surrey
Posts: 781
Meeshies bad newbie
Reputation: 0
I'm having the same issue with my truck right now... I just did the fuel pump and I'm doing the alternator this weekend. It's a known issues on dodges. I do know on the newer model dodges that there was a throttle recall ... I don't know a whole lot about mechanics... anyone here would be able to tell ya that but I've been having the stalling and lurching forward issue with my truck for a while... Dirka even scanned my truck and nothing was showing up on it... I got the fuel filter changed as well as ran an injection cleaner or whatever that stuff is called through the tank and did a basic tune up ... and none of that resolved it.. Hopefully the alternator is the issue
Reply With Quote
  #12  
Old 07-08-2010, 03:45 PM
crazylike crazylike is offline
Make your own-iEdit Title in 'User CP'
 
Join Date: Apr 2007
Location: Westbank
Posts: 1,372
crazylike bad newbie
Reputation: 8
i found that on the passenger side of the truck there is a vent line which runs from the tank to the charcoal canister under the hood and mine had been damaged and thus causing the pressure build up in my tank.I have just been running it with the cap loose and at night i tighten the cap this way if it every gets stolen it not gonna go much further then about 20kms.
Reply With Quote
  #13  
Old 07-08-2010, 03:51 PM
Tinker's Avatar
Tinker Tinker is offline
Tinker Belle loves my
Swollen Member
 
Join Date: Jan 2007
Location: MR
Posts: 2,211
Tinker Good newbie
Reputation: 15
So bad for the pump to be pulling fuel in a vacuumed tank. Pump is weak and plugged canister was gonna be my diagnosis.
__________________
CANCER !!! . Life is to short for the petty stuff...so remember, Don't sweat the petty things just pet the sweaty things!
Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Style Design By: Resourcelabz.se