PDA

View Full Version : Overheating


Skitherz
04-18-2009, 01:21 PM
Just a general quick ask about why my truck overheats when im not even doing anything, started overheating while in a timmies drive-thru:dontknow: . Checked my fluids and they are seemingly full. When i start driving it cools down, but i think its only because of the airflow. Im stummped:confused0006:I'd bring it in to a shop but would rather not... Any ideas?

Thanks:rockhorns:

Spedley
04-18-2009, 01:29 PM
Is your winterfront still on? Is anything blocking flow? Maybe check the thermostat?

Skitherz
04-18-2009, 01:39 PM
No theres nothing blocking the flow, thermostat seems ok.. maybe replace gaskets?

Toyquad
04-18-2009, 04:31 PM
t stat stuck closed? does the upper rad hose get hot?

rad plugged?? with the engine hot and off.... feel the rad is there cold spots on the core?

timming to far advanced?
running lean?

lots of things can cause trucks to overheat.

Gaybait
04-18-2009, 04:35 PM
is ur fan kicking on or off? it assume it heats up cuz its not getting any cool flow from the front. My jeep used to be the same way.. when sitting the engine cpt heats up fast and when i drive again it cools..

westcoaster
04-18-2009, 05:59 PM
Fan shroud??

Good rad cap?

lizard
04-18-2009, 06:06 PM
bad clutch fan?? that would do it = no airflow at idle

radman
04-18-2009, 06:22 PM
if it dosent over heat while driving its probally an air movement issue, ie fan, mud and dirt in rad...

Briannishi
04-19-2009, 02:04 AM
What kind of truck/car is it does it have a electric fan?

85_GMC_4x4
04-19-2009, 10:57 AM
From the sound of it.... I'd guess that you don't have the shroud on there, or your fan isn't spinning.

MetalMan
04-19-2009, 04:49 PM
#1 Check coolant level #2 Check fan function (make sure you have the shroud)

Apathy
04-20-2009, 08:37 AM
do you have a fan shroud?

Must be a ford thing.. My 75 highboy does the same.

Foes
04-20-2009, 08:56 PM
fan clutch, my ford used to overheat when idling, i put a new, used fan clutch on it, and it fixed it right away

Skitherz
04-21-2009, 08:34 PM
ya i think its the fan clutch.. i drove it around and let it sit in the driveway for a min and the fan doesnt kick into high speed, its spinning but... it barely even makes a draft when i put my hand behind it between the block, well thank god for the auto wreckers!! Thanks y'all