PDA

View Full Version : toy v-6 3.0 problems.


Hello Kitty
03-12-2009, 10:05 PM
ok so buddy had his motor go, took my old heads and machined them, put in new rings blah blah. replaced everything toyota and new. new waterpump you name it..........

put it back together but now he has no coolant circulation, no heat and when he gives it some rpm's he can hear water gurgling noises behind the dashboard ?

new thermostate didn't help, with the rad cap off and new coolant in with a bit on the gas the water spews out of the rad ?

wtf ?
:dontknow:

tchevy
03-12-2009, 10:36 PM
i take it its overheating too.....maybe the impeller sheared off, aftermarket water pumps can be just sometimes

BrokenToy
03-12-2009, 10:37 PM
sounds like it's hydro-locked or got an air bubble in the line to the heater core but i could be mistaken. definitely sounds like jammin up somewhere if you got no coolant circulation

dirka dave
03-13-2009, 02:37 AM
Sounds like a hose might be hooked up backwards....


possibly a heater hose or a bypass hose...

Apathy
03-13-2009, 08:23 AM
try this,
open radiator cap, start engine, let it warm up.. it might puke a little coolant, but shouldn't much. after that the level goes down, dump more coolant in.

This is how i have to do my nissan or i get the same problem.

Hello Kitty
03-14-2009, 10:34 AM
try this,
open radiator cap, start engine, let it warm up.. it might puke a little coolant, but shouldn't much. after that the level goes down, dump more coolant in.

This is how i have to do my nissan or i get the same problem.

we done did dat though.

:happy0045:

Trooper
03-14-2009, 11:02 AM
You put the head gasket on the right way? I put the head gasket on upside down on a mg and had the exact same problem.

tchevy
03-14-2009, 11:23 AM
t stat in backwards?:dontknow:

Hello Kitty
03-14-2009, 11:34 AM
You put the head gasket on the right way? I put the head gasket on upside down on a mg and had the exact same problem.

actually he put the heads on the wrong sides. toyota said it fine they are both the same but the distributer had to have a knick taken off to fit.

gaskets were put on fine as far as i know. shit i hope he put them on right.

[16]

Jayota
03-14-2009, 01:57 PM
air trapped in the cooling system. Jack up the front end a good foot or two, and then burp the rad.