PDA

View Full Version : basic dodge charging problums..


ROBO
12-09-2008, 08:41 PM
haven wierd stuff with my charging system, lookin for ideas.. good strong batteries, 120amp dual pully alt external regulator NO balast resitor,lol...so my vlots at idle sit around 15.8 to 16.. rev it up with load ..16-17 now when my lights are on there bright and wokin, but they strobe with the idle.. and brighten a bit when its reving, now just seems like its overcharging tryed 4 differtn volt regs .. no change. should i look at changin or testing the alter?

pumpkin
12-10-2008, 07:09 AM
Make sure the alt is properly grounded. Also check the voltage at the regulator.

nbrowser
12-10-2008, 08:14 AM
Yah....sounds to me like the regulator is fuckered....get it checked.

pumpkin
12-10-2008, 08:35 AM
I also seem to remember that the high output alts for dog ges have a different regulators.

crazydude
12-11-2008, 09:07 PM
Im having the same problem but havnt dove in to it enough I think its the alternator. And the regulator is built in isnt it?

dirka dave
12-11-2008, 09:14 PM
Regulator NFG.

ROBO
12-12-2008, 06:56 PM
reg is external and tryd noe 5 differtn ones from new too used same thing

dirka dave
12-12-2008, 07:32 PM
Is your voltmeter ok ?

Are you running an ammeter?

ROBO
12-12-2008, 08:37 PM
think i fixed it .. got pissed and smashed it with a hammer ... seems fine now.

slowdodge
12-12-2008, 10:33 PM
awesome

crazydude
12-12-2008, 11:06 PM
So what did you hit the reg or the altnator? so I know what to hit

ROBO
12-13-2008, 11:08 PM
alternator

78f150
12-14-2008, 01:15 AM
15/16 seems high i would say 14.7 is good

dirka dave
12-14-2008, 03:17 AM
The BFH is always a great tool.