PDA

View Full Version : weird problem


crazylike
11-12-2008, 01:41 AM
went for drive tonight on backroad locked the hubs in at the axels but the t-case stayed in 2high for some reason my right front brake gets really hot when i take it out of locke dposition and drive its fine but when i lock the hubs the brake caliper gets hot and the brakes start to make a grinding noise. Any Ideas?

crazylike
11-12-2008, 06:41 PM
no one has any ideas? tore the whole passenger side apart today right down to the axel shafts no noticble damage grease was still same color there was no metal shavings no scorching marks the hub works fine thought maybe it had piled up or something but its fine. Caliper is less then a week old brake lines are new master cylinder is new brake booster is new pads new only old part is the rotor.

dirka dave
11-12-2008, 06:53 PM
Wheel/unit bearing....?

crazylike
11-12-2008, 07:07 PM
its all new also axels rebuilt in the spring

sparkes3
11-13-2008, 08:16 PM
i was thinking wheel bearing

crazylike
11-13-2008, 10:15 PM
i'm leaning towards bend or warped stub shaft or spindle bearings since it only happens when i engage the front axel shafts. hoping to have new parts tommorrow.

crazylike
11-15-2008, 11:16 AM
damn it the parts where from a 44 anyone have some dana 60 front spindles ?

FU Toolbag
11-15-2008, 10:25 PM
Wheel/unit bearing....?

it won't have unit bearings if it's got locking hubs. How are the brakes on the other side? It also might help telling us a bit more about your truck, I know you've probably posted about it, but I'm a lazzy fucker.

crazylike
11-15-2008, 11:41 PM
its a 89 w150 with dana 60 ff axels 4 10 gears new calipers new brake pads new wheel bearings inner and outer new seals only old stuff is the rotors and spindles and axels shafts

importcrusher
01-10-2009, 12:33 AM
replace the brake hose yet?

crazylike
01-10-2009, 12:04 PM
all brake lines front and rear have been changed