PDA

View Full Version : no balls at low rpm big balls high rpm wtf!!!


CromeY
10-29-2008, 09:22 PM
k so my jeep hasn't been running quite right since i got it and now its worse every once in a while when im driving it starts to jerk like theres no fuel, does it a couple times then stops and may not do it for a day or two and while im trying to gain speed its so damn sluggish at low rpm till i get the rpm up then it seems to do fine and it runs really rich and i cant seem to figure out wtf it is i changed the o2 sensor it made a lil difference but nothing big and i changed the computer thinking maybe that, and it also likes to back fire while im letting the engine slow me down and only then never when im accelerating so if anyone has any idea what i could try changeing like any sensors or anything please let me kno also i dont think the distributor is in the right spot could that be the problem and if so how do i kno where to move it to so its in the right spot any help would be awesome gotta get this thing running before the snow flies got no shop only a drive way thanks in advance

superdoody350
10-29-2008, 09:34 PM
*****CUT OUT THE CAT******

CromeY
10-29-2008, 10:10 PM
has no cat

kootenaycat
10-29-2008, 10:15 PM
*****CUT OUT THE CAT******

Kelowna has no air care! [36]


Have you had the codes pulled? If it's a sensor or in the wiring, there should be a code stored, even if the check engine light isn't on at the time you pull them.

Backfiring out the exhaust or intake? I'd start with the basics, check plugs, wires, cap/rotor. All can cause backfiring, missfires, stumbling, etc. Is this the HO or Renix (pre '91)?

CromeY
10-30-2008, 04:06 PM
no i havent had the codes pulled and im pretty sure the back fire is out the exhaust plugs are brand new wires are brand new cap and rotor are brand new and its a 88 2.5 l

CromeY
10-30-2008, 04:07 PM
could it be my tps (throttle positioning sensor) and it was acting up but on the way home it seemed to fix it self and be running fine now it does this once in a while but sooner or later its gonna run like shit again

Happypants
10-30-2008, 04:14 PM
tps would cause it to idle higher, check your vaccume lines, near the map sensor and all other surrounding lines, check plugs, and the underside of your cap, also check the rotor too,

Apathy
10-30-2008, 04:34 PM
vaccuum leak

Vastier
10-30-2008, 04:41 PM
I'd put my money on the map sensor. Had to replace the one in my old jeep 4 times. It was a 97 2.5

CromeY
10-30-2008, 05:48 PM
it kinda sounds like there's rushing air by the map senor i cant figure out where its coming from though and it does idle really high so maybe its a combination of shit happening well this weekand ill change the map the tps and check for a vacuum leak and if its none of those im fucking stumped once again

Apathy
10-30-2008, 05:54 PM
start with vaccum leak man, i changed a MAF on my old expedition.. only to find out later it was a split vaccum line. 110 bucks.. down the drain

CromeY
10-30-2008, 06:24 PM
i got a extra map and tps so im not buying brand new but i kno those ones are working properly but how am i suppose to find a leak i can hear it when the engine is running but i cant pin point the damn thing

Happypants
10-30-2008, 06:46 PM
alot of times, the vaccume line FROM the map sensor will split and crack, start at the map sensor, and follow it, it usually cracks in the stupidest place where you cant see it,

CromeY
10-30-2008, 07:10 PM
am i just feeling for a crack or should i have the engine running and feel for air coming out or being sucked in?

Happypants
10-30-2008, 07:24 PM
you shouldnt need the engine running, just look at all the lines, feel them, most of them are a hard plastic which is fucking stupid cause over time they weaken and break off,

Apathy
10-30-2008, 07:32 PM
with the engine running, BE VERY carfull, start tugging and lightly moving around vaccuum lines.. the sound will change if you hit the right one.. kinda like.. PSSSS, PST.. PSSSSSSt.. hope you get the point

CromeY
10-30-2008, 07:40 PM
well hopefully i can figure this shit out i really wanna start the build but i cant till the engine is strong

Happypants
10-30-2008, 07:51 PM
seems like your having lots of problems with it?

nbrowser
10-30-2008, 07:56 PM
with the engine running, BE VERY carfull, start tugging and lightly moving around vaccuum lines.. the sound will change if you hit the right one.. kinda like.. PSSSS, PST.. PSSSSSSt.. hope you get the point

and just to add to this, the engine RPM will also increase a bit as you find vacuum leaks.....it'll start sucking more air in, I had leaks at of all places my front axle vacuum motor.....fixed that and things seem fine now.

CromeY
10-30-2008, 08:25 PM
yea ive been haveing troubles with the damn engine but the body is in really good condition so i wanna try and get the motor going but every time i think i got the problem fixed bam not that and im getting really frustrated and i cant seem to figure it out

Happypants
10-30-2008, 08:34 PM
fuck that sucks doood, thats the thing about jeeps though, but once you get it all figured out, your gold

CromeY
10-30-2008, 08:39 PM
yea the shitty thing is my old jeep shitt fucking body have the floor was rotted out hadda replace damn near hole thing but the fucking running gear was amazeing ran like a top sept body was shit so i bout this one cuz body is awsome shape sept running ear giveing me a hard time just cant win right now jsut cant wait to get it fixed and once i get my shop i can rebuild the new motor for it so then im good but for the mean time i needa get it running good cuz im only getting like 200 km on a full tank off gas like wtf is that so hopefully one of u guys are right and i get it fixed this weekend

CromeY
10-30-2008, 08:40 PM
the drive train was amazeing*

boogyman
10-30-2008, 09:18 PM
use a propane torch open the valve just enough to here the gas leaking run the tip over all vaacumme lines with engine running if there is a vaacumme leak it will rev up when you hit it with the propane check around base of throtle body or injecters wichever it has if that doesn't work after trying all those stupid sencers check the timing belt or chain and good luck hope it's something stupid that you find quick

Tinker
10-30-2008, 11:25 PM
Bad fuel pump, clogged charcoal canister. just my two bits and to keep ya guessing.

D-Ass
10-30-2008, 11:34 PM
boogyman use a propane torch open the valve just enough to here the gas leaking run the tip over all vaacumme lines with engine running if there is a vaacumme leak it will rev up when you hit it with the propane

this is one of the best ways to find a vacume leak if there is one it will get you really close to where the leak is insted of just pulling at hoses[cheers]

CromeY
10-31-2008, 03:58 PM
thanks everybody for the advice i gots lots to try this weekend now befor i had no clue now i gots lots to try thanks everybody hopefully one of u guys are right thanks again

g-rod
10-31-2008, 06:08 PM
man my 2002 dodge is the same way

CromeY
10-31-2008, 09:47 PM
maybe same problem

HEAVY METAL
11-01-2008, 08:05 AM
burn it.....yo

Reeseman
11-01-2008, 08:06 AM
I would try a fuel filter. and if that dosn't work . check your engine ground.

CromeY
11-01-2008, 08:46 AM
gots a new filter maybe ground problem