PDA

View Full Version : 91 xj rpm problem


Happypants
09-01-2008, 05:03 PM
got a 91xj 4.0L HO 5 spd, it dosent rev past 2000 rpm for some reason, i checked all the vaccume lines, replaced the plugs, wires, checked the cap and rotor, new fuel filter, replaced the o2 sensor, still no luck, anyone have any problems like this before??

Gaybait
09-01-2008, 05:05 PM
your a cunt, i actually listened to your advice and i was going t o buy that one u prick! haha

Happypants
09-01-2008, 05:07 PM
hehehe, WHAT!?!? i need a new body, why you gonna buy it, selling your zj now?

4Lo
09-01-2008, 05:21 PM
Could be a plugged cat.

Happypants
09-02-2008, 12:22 AM
im gonna check the cat when i get home from oregon on thursday, pickin up fancy new dedenbear knuckles and chromoly highsteer arms woot!

lornix
09-02-2008, 10:02 AM
I had the same thing happen in my old Chevy van. It was a plugged cat.

Happypants
09-02-2008, 12:57 PM
i pulled the o2 sensor, and started it, and it revved past 2000 rpm, then put it back in and tried it again, and it bogged, so i grabbed my sawsall, and chop chop, and it revs past, and runs friggen awsome!!! not too bad for 200 bucks lol, got a few other things i gotta get before nov when i tear down the old jeep and build this one, gonna get CAI system, banks tourque tube header, and...obviously...new exhaust and cat lol, thanks for the info guys,

CromeY
09-02-2008, 05:00 PM
hey whitetrash where u buy ur lift from? and did u lock the original axles or swap the old ones out?

Happypants
09-02-2008, 05:07 PM
my lift is rubicon express, got it from national 4wd in langley, i never locked the origional REAR axle cause it exploded before i got the chance to, i have a welded ford 8.8 in the back right now,and the stock d30 in the front thats open and has bigger shafts and u-joints,

this jeep is getting front and rear d44`s