PDA

View Full Version : my jeep hates highways...


offroadordrift
08-19-2008, 03:25 PM
so last week or so i had to go to chilliwack. i get there pull off the high way and my jeep dies. will not fire.the starter was kicking over but it wasnt getting fuel, the relays are not dead. i had brand new spares so i checked that first.
i dont ussually go over 90-95 k. but i had it running at 100-105k on the highway. would that cause my fuel pump to over heat and crap out?

its been down since then and im going crazy without it. any help would be great[cheers]

dirka dave
08-19-2008, 04:17 PM
Fuel filter could be pluged.

Always broke
08-19-2008, 04:21 PM
What type of Jeep Engine etc.???

Ginger Snaps
08-19-2008, 04:23 PM
do yourself a favour burn it and buy a ferd

offroadordrift
08-19-2008, 04:28 PM
do yourself a favour burn it and buy a ferd
NEVERgo fuck yourself

im not sure what motor. i know its a 86 cherokee with a 2.5 ltre 4banger with 428thousand clicks:D

the fuel pump doesnt even click on but i know i have power right to the tank

dirka dave
08-19-2008, 04:32 PM
turn the ign. to on, listen for the pump to prime....

offroadordrift
08-19-2008, 04:34 PM
i have dont that. i had problems before. but it was a weak ground...

im wondering if it overheated cause it was working too hard?

dirka dave
08-19-2008, 04:37 PM
Could be, sometimes they just die....

offroadordrift
08-19-2008, 04:39 PM
well im going to pick a part and im gunna get a whole new gas tank and pump. hopefully that will elimate my problem

Jeep_Explorer
08-19-2008, 05:34 PM
i have dont that. i had problems before. but it was a weak ground...

im wondering if it overheated cause it was working too hard?


I believe pumps tend to overheat more often then not when the tank is close to empty, because the fuel cools the pump inside and out.

dirka dave
08-19-2008, 06:13 PM
Do it with some logic.

1 check fuel filter

2 check pump

3 check relay

giggityjeep
08-19-2008, 06:45 PM
NEVERgo fuck yourself

im not sure what motor. i know its a 86 cherokee with a 2.5 ltre 4banger with 428thousand clicks:D

the fuel pump doesnt even click on but i know i have power right to the tank

maybe its just tired and wants to go to sleep now.

Little Samurai
08-19-2008, 08:35 PM
Had a pump burn out on my Samurai last year...rusty fuel tank = clogged fuel pump = burned out fuel pump = truck no workie. Getting a new tank and pump would be a good start with that kind of mileage.

offroadordrift
08-19-2008, 09:07 PM
alright thats everyone for the advice. i was thinking about gettin a new tank anyways for the same reasons you mentioned

Chopstick
08-23-2008, 08:16 AM
you should check to see what the voltage is going to your feul pump before putting in a new one !!! there is a little resister under your hood that tones down the voltage, if that burns out then it kills your fuel pump. its white with 2 wires. on my 91 its on the top right under the hood..

Josh_M
08-23-2008, 10:54 AM
First run 12 volts directly to the pump to see if its working. then go from there . Definitive way to see if its the pump is to turn on the igniton, and then check the wires going to the pup. If they're getting 12 volts the pumps fucked

offroadordrift
08-25-2008, 01:13 AM
alright. so i got a new pump out of a jeep at picka part. cost me like 30 bones!

came home and installed it. my jeep is back to kicking ass! thnkas to everyone for your input!