PDA

View Full Version : problems with my 87 ranger


T.Mart
04-25-2008, 10:20 PM
hey, i just got a 87 ranger and i recently swaped in a different 2.9l engine, and it seems to be running good but it has to power:dontknow: i tryed to drive up a hill near my house and it only make it about half way and im really confused as to what might be casueing this. please leme if have any suggestions on what it might be

thanks

tyler..

MikeWild
04-25-2008, 10:59 PM
2.9 is gutless at the best of times on a hill, what other symptoms do you get?

C.W.
04-25-2008, 11:05 PM
Whats your fuel pressure at?

T.Mart
04-25-2008, 11:37 PM
well i drove it around today and i could barley get it to go 50km

T.Mart
04-25-2008, 11:38 PM
and im not sure what my fuel pressures at ill check it tomorow

FINGERS
04-25-2008, 11:56 PM
hey, i just got a 87 ranger and i recently swaped in a different 2.9l engine, and it seems to be running good but it has to power:dontknow: i tryed to drive up a hill near my house and it only make it about half way and im really confused as to what might be casueing this. please leme if have any suggestions on what it might be

thanks

tyler..

what the hell you say it has to power???

T.Mart
04-26-2008, 12:44 AM
sry i ment it has no power

Always broke
04-26-2008, 12:47 AM
Could be a plugged CAt OR TIMING IS OUT A LITTLE

radman
04-26-2008, 06:13 PM
auto trans?, does it cough and sputter?

T.Mart
04-27-2008, 05:53 PM
manual and it hesitates when i push the pedal

jonny6door
04-27-2008, 06:02 PM
air/fuel ratio?? is it carb or efi?
________
MARRIAGE ADVICE (http://www.love-help.org/marriage-advice/)

T.Mart
04-27-2008, 09:41 PM
its efi

MikeWild
04-27-2008, 09:48 PM
MAF sensor? :dontknow:

Bulldozer
05-08-2008, 02:42 AM
If your gonna start taking it apart check the fuel rail also, they tend to rust up inside and foul the injectors.

HEAVY METAL
05-08-2008, 08:29 AM
burn it...

Kinslayer
05-08-2008, 11:24 AM
Fuel filter/fuel delivery. You say when you hit the gas is harsh lags? That's the motor not getting enough fuel for the air you just dumped in.

Rdnk_Wmn
05-08-2008, 11:43 AM
burn it...
[36] [36] [36]

radman
05-08-2008, 12:14 PM
throtal position sensor?

Cwheeler
05-11-2008, 12:43 AM
change the fuel filter, cheak the fuel pressure, it should have at least 30lbs to run properly, also try cheaking the plugs, wires, cap, rotor etc. if everything seems to be ok, it could very well be a clogged cat. is the check engine light on?