PDA

View Full Version : Truck Dead, Won't Start Help


Gaybait
04-19-2008, 07:47 PM
went to start my 97 grand cherokee limited and it was dead. I got jumper cables and tryed to start it. It would fire up but would stall out if i wasen't on the gas keeping the rpms up. would this be my alt, or possibilly my battery. My battery looks to be leaking a bit but if it started would the alt not keep it running??

Need to get it fixed so any help is good help.

Thanks

Chody
04-19-2008, 08:30 PM
sounds like the alt... take the bat out and take to crappy tire, they test for free, i tyhink they test alts to out of truck

bcwheeler
04-19-2008, 10:55 PM
check for a loose ground at the computer box james its back left corner of the engine comparment.. tap the smaller of th etwo boxes and wriggle withthe wiring harness.. Check ur battery terminals as well if its leaking mine does the same shit its just corroded terminals I keep a led pip for beating the shit out of them to make it start lol

hoser
04-19-2008, 11:04 PM
sounds like your tires are low:dontknow:

FINGERS
04-20-2008, 04:10 AM
ITS THE BLING

MikeWild
04-20-2008, 09:15 AM
ITS THE BLING

[15]

The spinners need to be spinning in order to recharge the battery.

Kinslayer
04-21-2008, 12:26 AM
It would fire up but would stall out if i wasen't on the gas keeping the rpms up. would this be my alt, or possibilly my battery.

Thanks


If you have to keep revving it to keep it running then your alt works. If your battery is dead that is inconcequential, it's a v8 i'm pretty sure the drag from an alt wont stall one of those out..sounds like one of the other two requirements for a running motor isn't up to snuff.

Mazdarx
04-21-2008, 06:29 PM
On a newer Jeep like that though, if you aren't getting proper voltage from the battery it wont run right. You should get that tested first, and then you can take it from there