PDA

View Full Version : Idle surging/ running fuct


-beaker
01-27-2008, 12:59 AM
I got my truck a pretty twist today in a trail up eagle, it ran good before i got stuck but when i got pulled out it started idling really bad, surging and cutting in and out when we started to drive, no clue what happened but it is also using ALOT of gas, like 3x as much, almost didnt make it hope it just kept sucking the shit in:confused0006: . This really is pissing me off and i have my exams this week in coquitlam so downtime needs to be next to nothing. Any suggestions on what to even start with:dontknow: .
1990 f250
4.9L inline six efi
dual tanks.
If you guys need anymore info or better descriptions to help me out just ask, It didnt smoke much from what i saw but smelt pretty rich?

pumpkin
01-27-2008, 09:37 AM
Check the vacume hose to the preasure regulator. Fords are good for sucking feul through the diaphram. After that just proper efi diagnoses.

-beaker
01-27-2008, 12:09 PM
Where is the regulator located under the hood?

ryan77
01-27-2008, 02:57 PM
72727

heres a pic of when it was stuck... pretty good flex for a ford :dontknow:

-beaker
01-27-2008, 05:06 PM
Check the vacume hose to the preasure regulator. Fords are good for sucking feul through the diaphram. After that just proper efi diagnoses.
You were right about the vacume line, i im not sure on a couple things that got disconnected so im going to check it against my teachers inline six, Would bad compression be a result of running no cats and a cherry bomb?

blacker_69
01-27-2008, 09:15 PM
the regulator is on the fuel rail supplying the injectors. check eng light on? gotta pull the codes, need a ford ngs to pull codes or aftermarket equivelant scanner. then youll know where to go, could be things ie coolant temp sensor, o2 sensor, stuck open injector etc......