PDA

View Full Version : Help!


chevy_gurl
01-06-2008, 01:01 AM
I have a 85toyota 4runner lifted and all.but its running like a peice of poo! Its a 22re feul injected 4cyclinder. Anyways it running like its sputtering , at idle certain times it revs its self. and once going it sputters in certain gears and it bogs out on certain inclines. Any ideas???

Hello Kitty
01-06-2008, 01:35 AM
check all yer wires, cap rotor , timing, etc.

make sure the halagen fluid is up to par also.


[36]

Bocephus
01-06-2008, 02:11 AM
gotta hate the halogen fluid bein low u might need a metric crescent wrench to fix this problem

Murd0c
01-06-2008, 02:22 PM
try your fuel filter kinda sounds like the same probelm I had with mine

TWOZEROFOUR
01-06-2008, 06:15 PM
sounds like a the usual muffler Bearing issue

HEAVY METAL
01-06-2008, 06:19 PM
tell troy its no good and too drop it off at my place...

thanks..

Thunder Fish
01-06-2008, 06:19 PM
guessing fuel filter also

chevy_gurl
01-07-2008, 02:03 AM
We have already changed fuel filter, cap rotor wires and plugs... soo yeah.

Kinslayer
01-07-2008, 08:04 AM
Don't worry about it, it's a Toyota, nothing goes wrong with them and they run forever so long as your change the oil.

Wait..have you changed the oil?

Toyquad
01-07-2008, 04:01 PM
i can have a look at it if ya want chantelle

toyon35s
01-07-2008, 04:03 PM
cheak the fuel rail on the injection for leaks,my bros toy did the same thig,cleaned the fuel rail and now it runs gooder[cheers]

flipper
01-08-2008, 11:18 PM
Don't run alcohol based fuel, caused same problems then died. My truck drinks at chevron now. Also may be dirt in mass air flow sens, causing reving.

dirka dave
01-09-2008, 04:02 PM
I have a 85toyota 4runner lifted and all.but its running like a peice of poo! Its a 22re feul injected 4cyclinder. Anyways it running like its sputtering , at idle certain times it revs its self. and once going it sputters in certain gears and it bogs out on certain inclines. Any ideas???
Clean out behind the throttle plate...Check the vaccuum lines etc..
If you want me to have a look at it pm me.. I'm a Heavy Duty and Automotive Mechanic looking for some side work... I live in Maple ridge and have been working on Toyotas for as long as I can remember.:confused0006:

Stetson
01-09-2008, 04:36 PM
Fix it yet? Lots of things it could be, sounds like you've started it the right area, poor spark is definatly a possibility, but check for the correct air flow going to the motor. Seen alot of 22re motors air intake hose crack along the flex hose at the intake manifold. when the engine torques, the hose separates a little giving the air flow meter a false reading thus reducing the fuel input and leaning out the mixture, pull it off and check it well, even a very small crack will make it run like that. do you have good compression in each cylinder? post back. good luck

StinkFinger
01-09-2008, 04:51 PM
Clean out behind the throttle plate...Check the vaccuum lines etc..
If you want me to have a look at it pm me.. I'm a Heavy Duty and Automotive Mechanic looking for some side work... I live in Maple ridge and have been working on Toyotas for as long as I can remember.:confused0006:


yeh but how long can you remember

duff
01-09-2008, 04:54 PM
been wheelin lately? check for water in yer gas

chevy_gurl
01-09-2008, 09:51 PM
My Bf has apparently checked the compression through each cyclinder and he was saying cyclinder 4 i think has spark and all but not "all" compression. I'll talk to him when he wakes up and i'll get the recent info on the beater.

Westonian
01-14-2008, 06:37 PM
Ummm anybody checked the TPS (throttle Position sensor). Thats what I"d do before anything else,

chevy_gurl
01-15-2008, 02:05 PM
well my gas tank is leaking now, we just put a new fuel filter on where there never was one before. when we changed the fuel lines that were bad the gas was black and grouse, drained it all out till clear. Then put new filter on now leaking and gas is blacker than black sooo... I need Gas tank.

dirka dave
01-15-2008, 02:09 PM
I might have a tank... I'll check next time I go into the deep dark toyota cave..

Redneck_04
01-16-2008, 07:05 PM
bad airflow sensor ive dealt with that problem before