PDA

View Full Version : CLICK sounds from hub


RAW
01-01-2008, 09:13 PM
Hey all... I am having a bit of a problem with my truck and am wondering if anyone can lend a hand explaining to me what you think it is.

During my little trip out to Stave today, I decided to check out some of the trails behind the river bed. When I locked the front hubs and driving in low I heard a clicking sound coming from my front driver side hub area. This happened while going very slow, straight, and on no incline. I was going through about 1/2' of snow at the time. I unlocked the hubs and it stopped. I tried locking again and it started up again.

Anyone able to give me any ideas on what this is? This is a new setup and should not be doing this.

Thx!
Randall
[cheers]

spit.fire.
01-01-2008, 09:15 PM
kind of front axle?

230
01-01-2008, 09:19 PM
Sounds like a universal.

RAW
01-01-2008, 09:26 PM
Please forgive me if this is a stupid answer, The only thing I know about the front end is I have "smurfields"

230
01-01-2008, 09:29 PM
Then i am wrong.

dirka dave
01-02-2008, 09:02 AM
jack up the front, lock one side then both, listen to the gearset, check universals and then if all is ok, take the hubs apart.

Toyquad
01-02-2008, 05:26 PM
smurfs make noise..... get used to it.... or get longs. as long as it isnt a cluck, or steering isnt inparied...... live with it.

flipper
01-08-2008, 11:31 PM
Edge of smurf might be hitting the housing as it turns, my longs are really tight but no sound from them.