PDA

View Full Version : Light wiring problems..


Lynx
12-16-2007, 06:26 PM
So when we got all the snow a little while ago im driving along and my headlights and dash lights were intermittent. Everything worked perfectly while on highbeam. Then last night I went to drive and I had no dash or parking lights. I looked at it today and the dashlight and parking light fuses were blown. So I put in a new headlight switch, which didnt solve anything. I replaced the parking lamp fuse and the dash and parking lights came on dim and the fuse started to melt/smoke so i shut it off. I sprayed out all the relays, and checked over the parking lights and everything seems to be fine. I also quickly looked over all the headlight wiring crap I could see and nothing smelt or looked melted.

Any Ideas?

nbrowser
12-16-2007, 08:07 PM
Go looking for a bad bulb, could have one of the dual filament bulbs doing something nasty, so check the headlights, tail lights, turn signal bulbs see if any look funny or are lighting up strangely.

rockrawler
12-17-2007, 12:08 AM
I just fixed that type of issue on a buddies xj and it turned out to be the plate lite wiring, it melted cause of the bulb. Or check to see if you have trailer wiring and it's showing bare wire, it can cause the same thing.

Lynx
12-17-2007, 06:43 AM
k thanks, i'll check that today

Irwin
12-17-2007, 04:00 PM
i got one for you cory...get a new jeep:)
hahaha

Lynx
12-17-2007, 06:13 PM
i got one for you cory...get a new jeep:)
hahaha

Suck it.

Thanks for the constructive input.

Lynx
12-30-2007, 04:24 PM
woohoo figured it out. Was something to do with the license plate light wiring/ground for the liftgate switch shorting or something.

Works now.

The headlight problem was unrelated. One of the main lighting harness connectors is under the airbox, and two of the wires were broken off one side of the connector. I just jumped those wires across the connector and everything works perfectly now.

I really never thought I was going to figured this out.