PDA

View Full Version : ticking when i excellererate


BCHunter
11-11-2007, 07:31 AM
any idea why i'd have a slight ticking only when i excellerate? it started 2 days back and now the "GEN" light is on

thanks

bakelite
11-11-2007, 07:51 AM
Maybe check the belt..could be a piece of it broken and hitting. Maybe took out a wire or knocked the plug off the alternator :dontknow: Had that happen on a tracker, drove me nuts til I seen it.

BCHunter
11-11-2007, 08:09 AM
i'll take a look as soon as it gets light enough..thanks

on that note i'v had a screaming belt a few times, only for the first few minutes when i start it up

UU
11-11-2007, 08:41 AM
exhaust leak, low oil ?????

Explorer guy418
11-11-2007, 09:44 AM
what engine?

92jeepcherokee
11-26-2007, 03:57 PM
my 1992 cherokee ticks when i accelerate as well and mine has a tiny split in the exhaust manifold by the collector pipe they are hard to see but i had tha same problem chek that out

Kinslayer
11-26-2007, 04:30 PM
i'll take a look as soon as it gets light enough..thanks

on that note i'v had a screaming belt a few times, only for the first few minutes when i start it up


Sounds like you alternator is on it's way out

Moondog
11-26-2007, 10:19 PM
The screaming belt on start up will be your water pump try changing the coolant make sure you flush all of the shit out. If that does not cure it you will have to replace the pump. The tapping is more than likely a hydrolic lifter on the way out common problem on XJ's

curlee
11-26-2007, 10:20 PM
or it's a bomb?? :dontknow: