PDA

View Full Version : old Ford out and about


patford
10-03-2007, 10:34 PM
After seeing Troy,s build got pump to take old wagon out for
fun. Lame pics but best I could do , still fun to bag on the old
girl . Any body got some tips on how to better brake pedal ?
All new brake parts 1 ton but always soft pedal with poor
braking ?

duff
10-03-2007, 10:40 PM
brakes have been upgraded? larger axels? did you upgrade the master to match?

Redneck Lincoln
10-03-2007, 10:42 PM
http://i226.photobucket.com/albums/dd219/RedneckDeluxe1990/GillRoadQuading012.jpg

Redneck Lincoln
10-03-2007, 10:43 PM
could be your brake booster, had that once. there is different boosters.
or if you've replaced the booster, it is adjustable.

patford
10-03-2007, 11:02 PM
brake pedal just sinks to the floor slowly , getting tried of bleeding
brakes , new master , proporsonig valve ? and calipers . Hey Redneck
I was the guy BS ya when wrecking your black truck out , on dirt bike .

Troy
10-03-2007, 11:03 PM
shes a beauty nice lookin rig!

try adjusting the little thread rod on the booster when you pull the master cylinder off. That should tighten up your pedal. If that doesn't work then the seals in the master cylinder are shot and time for a new one. Same deal on my other 79 i had.

jakerngr
10-03-2007, 11:05 PM
that thing is fuckin sweet

Ginger Snaps
10-03-2007, 11:07 PM
awesome rig man! hmm put that cab on a bronco frame and a super super super shortbox would be bitchen..!

78bronco
10-04-2007, 12:19 AM
that is a super sweet truck!!! wish that was mine!!!!!!!!!!!!!!!!!!!!!!!!!!

Redneck Lincoln
10-04-2007, 12:27 AM
brake pedal just sinks to the floor slowly , getting tried of bleeding
brakes , new master , proporsonig valve ? and calipers . Hey Redneck
I was the guy BS ya when wrecking your black truck out , on dirt bike .

ya, i know thats why i put pic of my truck up!!

epic3
10-04-2007, 12:37 AM
ya need a new master if it aint leakin and the pedal slowly goes to the floor

but real nice truck none the less

northernman
10-04-2007, 08:22 AM
[36] Right on man!!!![36]

GOT MUD
10-04-2007, 08:49 AM
nice looking rig, i would think it's the master or booster too, if everything else has been replaced, what else coulld it be. were those pics taken at jesperson Isl.

atoyot
10-04-2007, 10:46 AM
i do like those old fords

Redneck Deluxe
10-04-2007, 03:12 PM
it looks like peg? lincolns is at gill.....

gordwould
10-04-2007, 03:35 PM
damn i got to agree with phil:confused0006: sounds like master cylinder try bleeding were lines go in to the master and if it is brand new possibaly need to to bench bled again and check all of you rubber lines aswell for no restriction and that your rear brakes are adjusted properly .

m j
10-04-2007, 07:41 PM
did the rad and fan thing work out for ya?
been wondering about that for months

patford
10-04-2007, 08:00 PM
hey guys it my second new master , thought just a bad one .
also braid steel flex lines , master also bench bleed , think
go over it all second time. Never had a truck so hard to get
the brakes working good . Ya at Peg , hey MJ had a hard time
keeping temps. stable in spring , last time truck was on the road
was going to put some vents in the hood , but this last time at
Peg ran it hard in the sand , with both fans on it stay at 165
, best it,s done so far .

gordwould
10-04-2007, 08:11 PM
i once had a chevy (no diss intended) that i went through 4 masters before a good one from lordco and the last one was a reman fenco that worked drove me nuts

pistnbroke
10-04-2007, 09:28 PM
are you loosing fluid? is it a NEW master or reman?

patford
10-04-2007, 09:36 PM
first master new , pedal was soft , 1 ton , second master reman cause
it was all they had and the same soft pedal . Going to try to bleed it
couple more times then maybe rebuid my self .

Redneck Lincoln
10-05-2007, 11:19 PM
ya, had same problem with m/c's, try another new one. last year i had put four reman ones on and finally i had to drive to lordco in new west to get a new one and finally i had brakes!! pm me if ya need a hand!!

TWOZEROFOUR
10-06-2007, 03:00 AM
Nice Trucks

m j
10-06-2007, 10:46 AM
it takes 2 guys to bleed the fords
you have someone to hold the prop valve button?
you said new prop valve so you just took my #1 component out of the equation, those things are always buggered

Redneck Lincoln
10-13-2007, 05:30 PM
OWNED 77-79 FORDS FOR ABOUT 21 YEARS NEVER HAD A PROBLEM WITH A PROP VALVE.

Redneck Lincoln
10-13-2007, 05:31 PM
Nice Trucks


THANKS!!

Redneck Deluxe
10-13-2007, 05:36 PM
lincoln shouldnt you be working???

patford
10-13-2007, 11:19 PM
pull my prop valve out every thing was seize and rusted , got a new
brass from classic car that bolted in .

m j
10-14-2007, 12:20 PM
told ya so.
they are always siezed

Redneck Lincoln
10-14-2007, 07:53 PM
hmmm, i have never had a problem with them!! oh well, i cant be right alll the time! LOL!!!!!!!!!:dontknow:

Toyquad
10-14-2007, 08:27 PM
damn i got to agree with phil:confused0006: sounds like master cylinder try bleeding were lines go in to the master and if it is brand new possibaly need to to bench bled again and check all of you rubber lines aswell for no restriction and that your rear brakes are adjusted properly .



i check that first