PDA

View Full Version : CRAP!


Maelthra
07-13-2007, 09:15 PM
I'm trying to do a simple job on my dodge, installing the front brakes.

But for some reason, the passenger side Rotor is nearly a full INCH farther out (Away from the knuckle, towards where the tire would be) that the driver side was.

Heres the kicker: There is no bearing play, and it freewheels normally, like nothing is wrong. But the brake caliper and pads won't line up now. go fuck yourself

Any ideas? Please?

chevy69chevelle
07-13-2007, 09:24 PM
It's a dodge, it's normal. Best way to fix it I have found.... BURN IT

Maelthra
07-13-2007, 09:25 PM
Thank you for that. I'll do that right away. Definatly the most helpful person on this site, bar none.

[16]

MetalMan
07-13-2007, 09:36 PM
Take it apart and put it back together, if it was fine before it should be fine now. Unless you're trying to put the wrong rotor on...

the_balls
07-13-2007, 09:37 PM
might sound silly but when we did the hub on my buddy's we put the dust cover on backwards and had the same problem

Maelthra
07-13-2007, 09:42 PM
It did not have a caliper on when I bought it; that was one of the reasons it wasn't driving.

The rotors look the same, they were already installed.

I'm going to take the hub apart as soon as I can find the big effin' socket I need to do it.

Maelthra
07-21-2007, 01:14 PM
For the record:

The person who put the front end together before I bought did it backwards. Instead of putting the spindle right on the knuckle, he put the caliper bracket against the knuckle and bolted the spindle over that.

78bronco
10-02-2007, 11:50 PM
that sucks!!! glad you got it figured out