PDA

View Full Version : Stupid f*ckin 4 wheel


Big-Luke
02-18-2007, 11:19 AM
well as the tittle sez my 4 wheel wont engage on my 91 xj iv come to the conclusion that its my hubs cuz the front drive shaft spins so any other way i can maybe put manual hubs on or rebuild my current ones?

MetalMan
02-18-2007, 11:31 AM
Those things have hubs? By '91 I would have assumed it was all IFS.

FKN MRK
02-18-2007, 11:38 AM
[cheers] I had a similar problem with my yj this weekend. if you have a vaccume system that engages the hubs you should look it over very carefully. Mine got unplugged @ the transfer case by some branches or something. I will be changin that shit first chance I get[16]
Is the 4x4 indicator light commin on?

Gaybait
02-18-2007, 12:15 PM
no hubs.. arnt they just u-joints with uh..

MetalMan
02-18-2007, 12:37 PM
no hubs.. arnt they just u-joints with uh..

Do you try at being stupid, or does it come naturally?

DirtyComanche
02-18-2007, 12:44 PM
My gawd.


XJ D30 fronts have unitized bearings; which means they don't have hubs. The u-joints and axleshafts always turn. Along with the side/spider gears. XJs equipped with the NP231 tcase before 94~ (or something) used a vacuum axle disconnect on the long side axleshaft - essentially a shift fork that locks both of the long side inner axleshafts together. OFTEN these things fuck up. Check the lines that run to it from the tcase. Unless you have a NP242 (Part time and full time 4wd) in which case there's deeper trouble.


And ALL XJs are solid front axle.

MetalMan
02-18-2007, 03:34 PM
See I was 99% sure they had no hubs, but I wasn't sure if it was IFS or not...mostly solid axles have hubs. But Jeeps are just so gosh darned normal.

DirtyComanche
02-18-2007, 03:59 PM
See I was 99% sure they had no hubs, but I wasn't sure if it was IFS or not...mostly solid axles have hubs. But Jeeps are just so gosh darned normal.



Meh, newer SFA fords and dodges use a setup that is pretty much identical to the unitized hubs in jeeps, just a hair bigger though. There's people that even believe it is superior to having hubs and floating axleshafts.


I'm a guy who figures real 60s have hubs.

Kinslayer
02-18-2007, 04:48 PM
That goofy vacuum thing is crappy - broke on mine too.

The only Jeep that is IFS is the fucking Liberty.

Big-Luke
02-18-2007, 05:16 PM
i know its a fucking nightmare but i just blew my head gasket so its out for a couple days then ill worry about the 4 wheel

DirtyComanche
02-18-2007, 05:18 PM
Actually, there's the liberty, the commander, the latest grand cherokee, the compass, and *drumb roll* in about 1965~ they offered an IFS version of the wagoneer I do believe.


But umm, fawk that.

Big-Luke
02-18-2007, 05:25 PM
no shit dint know that

Justin_B
02-18-2007, 05:41 PM
Ya those vacum shit sucks, i just did my 4wheel on the cherokee i just got, and the little ball on the axle shaft was stuck, poped it open cleaned everything out and now its working again, but yeah things are finiky, and gay.
But i got the new petersons 4wheel mag and they have a thing in there to fix all that vacum shit, i was thinking about getting it, heres the website

www.4x4posi-lok.com

Fuzzydog
02-18-2007, 07:11 PM
Actually, there's the liberty, the commander, the latest grand cherokee, the compass, and *drumb roll* in about 1965~ they offered an IFS version of the wagoneer I do believe.


But umm, fawk that.


geez, and here I always thought you were just a great guy to get good parts from - turns out you have a wealth of knowledge to share too...:D

Big-Luke
02-19-2007, 03:13 PM
well looks liek im gona get a posi lock kit for my jeep next payday

Justin_B
02-19-2007, 05:56 PM
yeah cool product eh, pretty simple, alot better then vacum lines thats for sure. i might look into it aswell