PDA

View Full Version : Tranny mount Q's


fordpower
11-25-2006, 05:03 PM
Got a 88 F250 5.8L 5 spd with 60 front.. Anyone had the trannny ears on the tranny break off? Alum ? So the mount is no longer with the tranny? Any quick fixes? Weld or replace? Thanks for any addvice...[36]

89Ford
11-25-2006, 05:38 PM
hmm never had that that prob...and if it was alum i highly dount it be worth while to find an alum welder and all that shit....should prob just replace....but i couldnt tell ya for sure

4doorShorty
11-25-2006, 06:33 PM
at the bell housing where it joins to the engine? get it welded if thats where....ZF5s arent cheap and you cant just replace the bell housing, its integral to the case.

fordpower
11-25-2006, 07:08 PM
No its at the tranny/adapter.. Right between the tranny and T-case on the adapter. Two eyes the are threaded and the mount is bolted to it then to the cross member.? MrBOB and the same thing on his but only one broke. He had it welded but the tranny was out.. Anyone else?[36]

Punk in Drublic
11-25-2006, 11:43 PM
havent broke mine but i stripped the threads on both. i decided the easiest thing to do was swap to a 460 and C6....
I hate the way ford mounts the tranny. with my I6 and 4 speed i kept ripping the rubber mount to shreads, than eating mouter mount on driver side.

when you do fix it try chaining ur motor down, might help make life a little easier on the tranny mount.

gordwould
11-26-2006, 12:28 AM
try and find another center section (extension housing) because either way its easier to weld if it is out so you might aswell just get another one then get your broken one welded incase it happens again but i would check your motor mounts too just incase there the cause of the extension`housing mounting ears to break [cheers]

fordpower
11-26-2006, 10:22 AM
Thanks for the info boys I will look for another extension or just weld it.. Ya the right motor mount is cracked ant fucked... [36]