PDA

View Full Version : Staling when cold


89Ford
11-18-2006, 12:52 AM
Hey guys, Ive got a 89 F250, 5L. My problem is that when the trucks cold it stalls. When i 1st fire it up, the idle runs up to like 1500 or something then settles down to 1000 for a few seconds, then down to normal idle, ok all good, back out the driveway, and when i go to stop at the stop sign, if i dont quickly give the trottle a little blip it dies. And it will continue to do that for like 20 min till its warmed right up. If i save it from dieing, or come to a stop exstreamly slow it will keep running, but at like 500 rpm just barly hanging on. And on occation when its cold the engine light will flash on, but only for like 2 seconds, then t goes off again. So i need some help in trying to fuiggure out why its not idling properly when its cold....What sensors could i replace???? I replaced the O2 sensor hoping that would cure the engine light flashing, only happens like once a week....but it didnt help.

any tips much appricitated

Thanks Brian

pumpkin
11-18-2006, 09:57 AM
sounds like it should be properly diagnosed. Some possabilitys are egr staying open, bad idle air control motor, and coolant temp sensor. Start with checking those out.

230
11-18-2006, 10:22 AM
If the engine light is coming on it should trip the computer with a code.Try pulling the code and maybe that will be your problem right there.

89Ford
11-18-2006, 02:09 PM
ya, i fuiggured id have someone say to pull the code, ive been meaning to do that...just need mroe damm hours in a day..and thaks for some tips their pumpkin...i was thingking coolant temp as well