PDA

View Full Version : Installed my winch, and i have a question.


Sonofx51
10-30-2006, 11:13 AM
Well it only took me 8 months to get off my ass to install my bumber and winch.
I got it installed and had my buddy wire it for me. But i broke the brake on it. Is it really that important? Should i fix it right away, or just use it with out it.

Tmax
10-30-2006, 11:35 AM
what do you mean you broke the break? and how do you break it anyways?

Jeepnut
10-30-2006, 11:46 AM
yes you need a brake...............fix it soon

Sonofx51
10-30-2006, 01:39 PM
i pulled the brake lever to disengage it, and the bolt snapped off in the casing, so now i have to try and drill it out and use an easyout... should be an easy fix

Jeepnut
10-30-2006, 01:42 PM
yup sounds like it................

Tmax
10-30-2006, 03:02 PM
i pulled the brake lever to disengage it, and the bolt snapped off in the casing, so now i have to try and drill it out and use an easyout... should be an easy fix

thats not the break bud. just the lever to engage and disengage the cogs and yes you need that for sure. the actuall break is usually inside the drum and prevents the winch to spool out when uner load.

Sonofx51
10-30-2006, 08:45 PM
no it was the brake i'm sure of it.. cause theres another lever there that put it in and out of gear.

Hello Kitty
10-30-2006, 08:49 PM
thats not the break bud. just the lever to engage and disengage the cogs and yes you need that for sure. the actuall break is usually inside the drum and prevents the winch to spool out when uner load.

do you google then reply???



[15]

Tmax
10-30-2006, 09:10 PM
do you google then reply???



[15]


????????????????????????????????