PDA

View Full Version : YJ Clutch Help Needed!


kootenaycat
10-03-2006, 04:44 PM
Got a '90 YJ 4.2 5 speed at work I've put a new (Dynapak) clutch into, new slave, resurfaced the flywheel. Bled clutch system several times and pedal feels alright, has about 3/4" free play in the push rod in the master, can't get rid of it. Problem is clutch won't completely disengage and when it's in gear, the clutch grabs almost immediately off the floor. Doesn't feel like any air left in it, I even pulled the master off, tilted it to get the air out of the line.

Any ideas?

Thanks,
Kevin

In The Zone
10-03-2006, 04:59 PM
splines on the input shaft burred?

kootenaycat
10-03-2006, 08:12 PM
No, splines were clean/free of burrs. The clutch isn't acting as if the input shaft is hanging up (turning all the time), it acts as if it's out of adjustment, it engages as soon as the pedal leaves the floor, not even 1/2" ! If the pushrod was threaded, I think just taking 90% of the free play out of the top of the pedal travel would cure it. The clutch worked fine before I pulled the trans to change it. It was getting worn out, but still had 20% left. I'm thinking either the pressure plate is wrong design and the fingers to release bearing distance is too great. Or, there is a little air in the system, and it's not allowing it to release.

Nutbar
10-03-2006, 09:53 PM
I think it was Dayna pak clutches that Matt was having trouble with down at his shop he now uses Luk clutches.

and if you clutch is the aluminum master on it, it has a steel push rod on a steel pin on the pedal and they wear together and wind up giveing you free play in the throw.

kootenaycat
10-03-2006, 10:32 PM
Thanks Nutbar, I noticed there is a lot of play/movement in the pushrod in the master. But it didn't have this problem before I pulled it, so I'm leaning toward the Dynapak kit. At least I'm getting really fast at re&re'ing the trans! [16]

In The Zone
10-04-2006, 09:35 AM
yup i went with the Luk clutch pack and have had no issues..
shifts like a new Jeep.. mind ya pretty much everything else has been redone as well bellhousing ,slave ,master lines ect........

kootenaycat
10-04-2006, 11:10 PM
Took the master pushrod out and stuck a washer in there to take up the free play. When it was cold, it worked great, clutch disengaged perfectly. After a short road test it started doing it again. I'm thinking InTheZone may have it, splines on the disk might be hanging up on the input shaft. Getting a little stressed out with this job, glad it's a longweekend coming up! [31]

Matt
10-05-2006, 08:42 PM
what master you using? I've had problems with many aftermarket masters.

kootenaycat
10-05-2006, 08:57 PM
what master you using? I've had problems with many aftermarket masters.

Never changed the master, wasn't leaking, just changed the slave. It does have the aluminum master in it and the piston was worn where the pushrod hits, that's why I put a washer in there to take up the free play. Customer took it today to try it. It is perfect cold, but after a bit of a drive it seemed to start hanging up, at least yesterday it did. Hoping that if it's a burr on the clutch disk splines, it wears off! If not, he has a year of warranty on it.