PDA

View Full Version : HELP


Blazer
09-28-2006, 11:44 AM
I pulled in to work to day and the side kick just died, no power any were radio all electrical and nothing when I hit the key. I waited a bit and all the power came back on and fired right up If anyone has come a cross this any tips would be good.

T.O.
09-28-2006, 11:49 AM
Bad conection at the battery terminals:confused:

StinkFinger
09-28-2006, 11:57 AM
hi todd ........................................

T.O.
09-28-2006, 12:10 PM
Hey Stinky...........29300

T.O.
09-28-2006, 12:26 PM
.............................29303

Blazer
09-28-2006, 12:30 PM
Thanks..I checked the battery terminals they seem good .....any thing else I did have it barried in the mud up at stave on sunday if that helps.

REZ
09-28-2006, 06:07 PM
i had same kinda problem,( went swimming with my tracker)
and then it sometimes crank sometimes didnt.
i had 2 problems, one was my starter wire was grounding.
and once in while my fuse was puping out

Blazer
09-28-2006, 06:51 PM
Thanks, it got me home so I am going to check all the fuses and battery conections, the only differance is it wouldn't even crank over there was nothing at all.

rat trap
09-29-2006, 10:29 AM
your altenator is on its way out i changed mine had the same problem[41]

Blazer
10-14-2006, 01:24 PM
It turns out that the ignition harnes was shorting out at the plug, so I took it out (the ignition) service it and fixed the conection for the plug and its all good.

REZ
10-15-2006, 04:17 PM
good job buddy.........