PDA

View Full Version : Help - Charging Problems


SilverCherry
09-23-2006, 01:56 PM
Hey Guys

So we got a new battery, new alternator, and nstalled it all. She ran for a day perfectly. Then the next day some lights came on, AT Temp, Charge, and Ebrake. They flickered on and off. Took her to the shop last night. Got the lights to turn off, but when on the computer, she read NO CHARGE. However, when we pulled out a fuse and reconnected it, the computer read CHARGED for a brief 2 second period. All possible fuses grounds and fusable links seem good.

Anyone have an ideas on what could be going wrong????????:confused: :confused: :confused: [j]

trailburban
09-23-2006, 08:45 PM
i'd double check all grounds carefully, they seem to cause all my problems.
also check to see if you bumped a wire or pinched something during the install. you may have a wire that is broken internally that makes and brakes contact.

Tmax
09-23-2006, 09:00 PM
just put a charger to it every night and dont use your headlight


oh and fire your mecahnic

83Toy4x4
09-23-2006, 10:01 PM
Maybe your vehicle has a fusable link that is burnt out?

Dieseljeep
09-23-2006, 11:24 PM
Most alternater/starter shops will do a free charging system check ofr ya and pin point the problem ,may also be your starter,causing a drain I had this on my Toy.Check all the graounds and such make sure they are clean and use a die electric grease on the outside to help shield them from corrosion/dirt.Make sure the battery terminals are all clean too.as well as the alternator conections are clean and sealed.

Hyenuf
09-23-2006, 11:35 PM
http://www.thesmilies.com/smilie-generator/image/rolleyes%5E_%5Eimpact%5E_%5E6%5E_%5E3%5E_%5E%5E+YA %2C+WHAT+HE+SAID%5E%5E_%5E.gif

Also don't forget the alternater body itself... make sure it's mount points are clean..... better ground this way.. is it internally or externally regulated????

Make sure that the alt. is accually putting out ....I know this sounds basic but... hell ya never know!!

SilverCherry
09-23-2006, 11:39 PM
Its internally regulated.....

We took her to the shop today. Our mechanic is going to look at her Monday.

SilverCherry
09-27-2006, 08:13 AM
Got her all fixed up. The new alternator we put in was faulty too. We got another one in now, and all seems to be good.

Thanks Everyone!!

Gaelen
09-27-2006, 08:30 AM
whats with all the alternators?
yours...then mine...then manny's...whats next jays?

SilverCherry
09-27-2006, 08:38 AM
Yea no shit. Like you said....haha Its a virus!

3 trucks in a matter of 1 week. WEIRD!!!!!

epic3
09-27-2006, 09:22 AM
keep your diseased trucks away from mine then