View Full Version : My YJ....

09-06-2006, 09:23 PM
Today...new motor ran. :D Felt good too. [36]

09-06-2006, 09:24 PM
Cool Joe did ya just rebuild a 4.2

09-06-2006, 09:30 PM
Got one from Canada Engines Mike, had them put an rv cam in it. Runs sweet but got a bit of a miss thru all rpm ranges but we took out a shit load of vacuum lines hoses misc crap, trying to get it slimmed down. Gonna need some tuning but it's tight and sounds good. Needs exhaust too, still got the rotten cat on it and holes in the exhaust all over.

oops..yes another 4.2 :)

09-06-2006, 09:38 PM
Check and make sure you don't have an intake gasket leak, little hint the only intake gasket I use is the one that only does the intake ports the exhaust manifold is metal to metal seal from the factory when you use the one supplied in the over haul kits that surrounds both intake and exhaust they always end up with an intake leak.

And you did do the computer bypass didn't ya.

09-06-2006, 09:46 PM
Thanks, yup checked for intake leaks and seems fine but we did use the gasket from the kit [27] hopefully it's okay for a while. Did the bypass for sure and the carb was all loose, tightened it up, messed with the timing and it ran pretty nice. Cept that miss. Ran it for a while til it heated up then the heat dropped off, never got too hot. Will tighten the intake and exhaust again tomorrow. Got kinda tired today so we unhooked the battery and gave ourselves a break. Was a good day. :) Gotta check that bypass info again, I think we need to change the timing for it and maybe cuz of the cam too.

09-06-2006, 09:51 PM
Cool, now lets go wheeling :cool:

09-06-2006, 09:52 PM
Cool, now lets go wheeling :cool:

I am sure looking forward to it still lots of work to do but I'll get there man. [cheers]

09-06-2006, 09:53 PM
I usually set them at about 8 to 10 degrees at idle with the vacum disconected (on the bypassed jeeps) then I will play with the vacum source for the advance some like manifold vacum some like the ported vacum (the one on the side of the carb sticking out towards the valve cover)

09-06-2006, 09:55 PM
okay, thanks Mike, I'll try that out tomorrow, we got it set at stock timing right now. Really appreciate the info [cheers]

09-09-2006, 11:36 AM
Joe what if ya dont mind send me a pm on how much canada engines charged ya [cheers]