PDA

View Full Version : engine knock


sosk
08-13-2006, 12:58 PM
knocks on startup..4.0l xj

what to doo? engine gona die on me?

MUD CHILD
08-13-2006, 01:02 PM
Yup sounds like shes done

keep on knocken but ya can't come in[cheers]

sosk
08-13-2006, 01:03 PM
damn..maybe i wont trade for it then
haha

dirt balls
08-16-2006, 08:22 PM
try putting better gas in it i think its really common for 4.0 to knock a little when using 87 grade gas if that dont work get ready to get dirty good luck

bratboy
08-17-2006, 01:34 PM
could be low grade gas but if it goes away after a few mins. then i'd be thinkin' the oil pump might be going and not getting oil flow up to pressure until it is warm. mine have never knocked and i've had a couple of them so i don't know how "common" it is but it can't be a good thing thats for sure.

Gaybait
08-17-2006, 02:52 PM
i have the same problem in my 4.0L XJ, knocks for about 2 seconds maybe less just a quick knock then goes away for good untill it starts up cold again.. i used alittle of that Bardahl lubi shit and it seemed to help.. i think its just poor oil pressure... people have told me thats all it is in mine.. cuz my oil p gauge is at like 0 at startup while it knocks then when it stops it shoots right up to full so... u never kno right?

Pudge
08-17-2006, 03:32 PM
as far as I known, it is quite common for bottom end knocks on those, doesn't nec mean it's done. check with the Jeep god on this one (Nutbar)

J20
08-17-2006, 06:05 PM
i wouldnt worry about it all 4.0s knock eventually............

Nutbar
08-17-2006, 06:57 PM
4.0L are known for a constant knock that is piston slap due to an over square bore/stroke combo ( short stroke large bore ) sounds kinda like a deisel when idling but that knock never goes away. the knock at start up could be ( most comon things ) timing chain gets loose and rattles on the cover and rod bearing wear letting the rods slap the crank, both of those you can also hear if you rev the engine to between 2000 and 3000 rpm and feather between that band.

the 4.0s are not known to have poor oil pressure if it does it probably means that your crank and rod bearings are worn

ray
08-17-2006, 11:28 PM
knok senser would also set your timing back automatically
witch would make it run like crap could be timing chain or piston slap like
nutbar said