PDA

View Full Version : service engine light


Chev4.3
06-18-2006, 11:17 AM
what would cause the service engine light to come on and i have oil pressre and the light would go off for a bit them come back on

Jroc
06-18-2006, 11:20 AM
STICK A PEICE OF BLACK TAPE OVER IT!

ITS PROB JUST YOUR O2 SENSOR CUTTIN OUT (IF ITS THAT NEW?)

pumpkin
06-18-2006, 11:21 AM
Computer telling you thereis a problem.

crazy j
06-18-2006, 11:37 AM
burn it! :D

Chev4.3
06-18-2006, 11:58 AM
whould any one know or think of what the problem is

pumpkin
06-18-2006, 01:17 PM
Start by retreiveing the codes.

Big_Ern
06-18-2006, 01:20 PM
[stupid]

Toy_Runner
06-18-2006, 10:49 PM
i am up for the tape idea, or the burning

Chev4.3
06-18-2006, 11:30 PM
well it hasn't came on yet today

Plumb
06-19-2006, 01:44 AM
mines been on for 3 years in my Sonoma

runs great

Growly Gorilla
06-19-2006, 07:11 AM
probably an o2 sensor. Or a tps sensor or or or..................... could be any number of codes .

Chev4.3
06-19-2006, 10:00 AM
yea well hasn't been on since sat i porbly just had mud in there

pumpkin
06-19-2006, 01:00 PM
If it only comes one sometimes, could be an EGR code.

RIFF RAFF
06-19-2006, 01:43 PM
STICK A PEICE OF BLACK TAPE OVER IT!

ITS PROB JUST YOUR O2 SENSOR CUTTIN OUT (IF ITS THAT NEW?)



thats what we did in the dodge[15]

Cat Chaser
06-19-2006, 02:02 PM
I have a 95 chevy turbo diesel and the light comes on all the time I retreive the codes and it says MAP sensor all the time,the only thing I notice different is that the turbo does not open when the light has been coming on otherwise I just ignore it till it craps out.

Larry
06-21-2006, 10:14 PM
go to the dealership and pay the $30 for them to read the code