PDA

View Full Version : I KEEP SNAPPING...


HEAVY METAL
12-06-2005, 08:33 PM
the passenger side bolt on my 205/465 adapter.... anybody know why ths could happen? has it happened to any of you? i've heard somethin bout a bar between the tranny and transfer case? anyone have one of these?

-----------------------



I'M AN ASSHOLE.... DEAL WITH IT.... I HAVE....

redneck_justice
12-06-2005, 08:53 PM
dean get a bracket built that goes from t-case to frame. i was having same trouble with the s/box i got from digger. i think the bracket ur talking about goe's from bell housing to t-case. there are 2 hole's for this bracket on ur t-case and a factory rod go's up to the bell housing. i built a l shaopped bracket that went under the frame rail to hold the the adapter mount down from torqueing over and thus breaking the tail stock off my turbo 400. shoot me a pm with ur e-mail and will send ya some pics of mine.... caution may cause roll over.lol

it's my opinion...
and ur entitled to it!

In The Zone
12-07-2005, 03:31 AM
yup i agree need another brace/mount

HMMMMMMM
ITS a FORD

HEAVY METAL
12-07-2005, 04:19 AM
deanduncan@hotmail.com... thanks guys...

-----------------------



I'M AN ASSHOLE.... DEAL WITH IT.... I HAVE....

NickB
12-07-2005, 04:41 AM
Its all that horse power[15]

No its not cold out,its just really small

HEAVY METAL
12-07-2005, 05:18 AM
more than you chump.....

-----------------------



I'M AN ASSHOLE.... DEAL WITH IT.... I HAVE....

bakelite
12-07-2005, 05:54 AM
when I bought my truck the adapter was all cracked to shit from not being braced. i think the dukes of hazzard owned it. all good now.

Phil could ya send me some pics of that too please? hrf1@uniserve.com

dentedup
12-07-2005, 06:15 AM
are you using silicon or gasket between? just silicone wont alow it to seat properly

" its a chev in disguise as a trooper "

HEAVY METAL
12-07-2005, 06:24 AM
.hmmmm using silicone....awseome.... that means i get to take it out again!

-----------------------



I'M AN ASSHOLE.... DEAL WITH IT.... I HAVE....

England
12-07-2005, 10:30 AM
quote:Originally posted by HEAVY METAL

.hmmmm using silicone....awseome.... that means i get to take it out again!

-----------------------



I'M AN ASSHOLE.... DEAL WITH IT.... I HAVE....





Fun Fun Bro ...asked Mike ???

dentedup
12-07-2005, 11:00 AM
I've never had any luck finding the gasket from any where other than GM ( $ 26 ) . now I buy the gasket in the roll and make my own. I don't think you need that torque rod if the adapter is seated to the 465 and 205.

" its a chev in disguise as a trooper "

smitty454
12-07-2005, 02:27 PM
are you using rubber trans and motor mounts might want to look into poly ones if you are not allready running them.

boyzen
12-07-2005, 04:17 PM
I have one of those bars





If I had a vagina it would be as big as a garbage can..

HEAVY METAL
12-07-2005, 04:46 PM
how much you want Chris?

-----------------------



I'M AN ASSHOLE.... DEAL WITH IT.... I HAVE....