PDA

View Full Version : clutch problem


hornythrony
11-09-2004, 01:41 PM
i have a 91 ranger with a hyd. clutch and at the rod hooked up to the pedal it leaks is there a rebuild kit or do i have to get a new one and if i need a new one where do i get it?

Big_Ern
11-09-2004, 01:49 PM
Not sure how different Ford are than Toyota, but I wouldn't recomend rebuilding it -- I did mine about a month ago and its leaking again already.

The problem is that the cylinder has such tight tolerances that putting in a new piston and seal (O-rings) still won't make it seal good enough.

I'll be replacing mine with a new one from the factory asap

Sambuca id da debil!

***The REAL Hairy White Ass!***

'89 4Runner w/ 33" Swampers

factor
11-09-2004, 01:55 PM
get a new one their not that expensive and check slave cilinder it may need to be replaced too. esey to change in the driveway not so ezy on the side of the road with no parts and no tools in the rain in the dark. it sucks!

godzuka
11-09-2004, 01:58 PM
just change the master and bleed the system. the slave is a pain to change so hope that it doesn't leak. its about a 4hr job on a hoist.

I don't have an intolerance to alcohol, I have an intolerance to people while drinking alcohol.

hornythrony
11-09-2004, 02:19 PM
yeah slave is not leaking atleast hope its hasent start i just rebuild the tranny and put it in to fine out that the piston is leaking any good places to get it and my slave the hose going in i cant get it out it doesnt have that plastic ring and it trashed any good ways to do that?