PDA

View Full Version : I have to work on one


BigC
12-01-2003, 01:29 PM
[41] OK I have to work on a FORD[j] I found a 80 Bronco for my girlfriends sister. We bought it a Non Runner. The old man said"he jump started it backwards this stuff here smoked" Anyway I have replaced the starter solonoid, Voltage reg, battery, battery cable,ignition mod, coil, cap, rotor, plugs, wires and now a fuel pump. Its turning over and still not gettin fuel, the line is dry, I've undone the line at the tank and blew through to the carb no problem, and into the tank, still no fuel[!]FORD

"What color are ya gonna paint it?

boyzen
12-01-2003, 01:44 PM
Check if the fuel pump is actually getting pumped from the cam lobe or if something is not activated the pump, try an electric fuel pump.Is it a new fuel pump ?mabey its faulty.

Shit always happens

BigC
12-01-2003, 01:53 PM
[27] Ya I'm gonna splice in and try and suck from a jerry can tommorrow, but I can squeeze down on the pump and make some mating sounds out of it[a] Oh and I also have put $25 in the tank so it's got fuel.[!] ON THIS BRONCO

"What color are ya gonna paint it?

Broncoo
12-01-2003, 02:02 PM
hmm electric fuel pump is good idea 5-7psi is what we need (and a block off plate for the mechanical one) maybe we try that?

FU Toolbag
12-01-2003, 11:43 PM
With a new fuel pump and still no fuel it's probably the lob is gone. If that's toast, I'ld bet so is the timing chain. Check it by popping the cap off the dist. and turn the engine over by hand, one way, then the other. Watch the dist. rotor. If there's some lag when you change directions, plan on a timing chain as well.

OKOR[f]
72 super beatle
1 lwb Sammi- 2.4 deisel
1 lwb sammi "avalanch"
1 suzuki lj 80- toy axles, 2.3 turbo power
1 69 tlc- straight frame, 350 power
1 75 tlc-custom everything
1 76 tlc-stock, not for long
1 80 bronko-propane 460-sycadelic.
1 98 FJ40, 4 tones'o'fun

BigC
12-02-2003, 04:20 AM
Cool thanks OKOR I'll try that next![2]

"What color are ya gonna paint it?