PDA

View Full Version : electrical problem


barracuda
10-18-2003, 09:58 AM
Ok here is my problem (my trucks not mine ) in the recent storm we lost powere to our hous so i figure that i will just start up the welding truck and bring it over and power a few things(sump,well pump etc , not hooking power to the house though) now i go over and i find that my trucks battery is dead[xx(] i had used it the day before and it was fine:D. allright i thought it might be that i had left a light on or something?[?]? so i decide to jump it:) . well it seems as though that the truck wont turn over worth a shit [}:)]??? so i think perhaps the battery is so far gone that it is sucking the power to charge the battery so i disconnect the battery and link to the terminals direct from my hunting truck still does not turn enough to start what the fuck is going on???[13]??? all the connection are ok it just seems as though it is shorting out or bleeding off voltage cause of the water [V]. The truck is a 19 90 ford is this common with these trucks
By the way we ended up running power cables from where the truck sat to the pumps and stuff

"A level" mobile welder
migImage Insert:
http://www.funinbc.com/forum/uploaded/barracuda/200361401938_scan0001.jpg
32.46 KB

,tig,alum spool,stick
email me if you want some work done

The way to a mans heart is through his zipper!!!

sj-x 500
10-18-2003, 10:10 AM
try to search out your ground leads.. one might have fallen off. didn't turn over on jumpers you say? starter maybe be gettin grounded enough... if you have the ability, do a quick load test on the battery. about all i can thin of

84 sj410 with 16v w/EFI, auto 4-spd, 4.63 gears, 7 inches wider then stock, 31x10.50 mickey thompson baja claws, 6 + inches of lift
broken u-joint count: 2

KBB
10-18-2003, 10:41 AM
Maybe a screwed starter. check your ground. do you have voltage?? If so, you maybe not be passing current. Clean up most of the connections



http://www.funinbc.com/forum/uploaded/killerbugsbunny/2003101895721_bart6.gif
You'll be kissing me here!

barracuda
10-18-2003, 01:31 PM
I dried the fucker out jumped the battery and the truck seems fine now????? go figure ??? I guess the electrics dont like to be water logged I think i will make sure all is connected and protected before the next RAIN STORM!!!!!!!

"A level" mobile welder
migImage Insert:
http://www.funinbc.com/forum/uploaded/barracuda/200361401938_scan0001.jpg
32.46 KB

,tig,alum spool,stick
email me if you want some work done

The way to a mans heart is through his zipper!!!