PDA

View Full Version : 5.4


longhorn
01-25-2016, 07:26 PM
I have a 2007 F-150 with a 5.4.
Runs decent if you feather the gas but if you put your foot in it , it bogs
right out and starts losing power.

It will do 140kms like nothing if you work your way into it , but ask for it all at once and it almost quits?
Anyone know?

96_z71
01-27-2016, 05:26 PM
Neighbours 06 f150 had similar problems. Heavy hesitation, missfire, low power under load. Changed the plugs and it ran mint. Plugs had about 85k on them. Luckily none broke. Any codes? Cat might be plugged or something too.

Little Samurai
01-27-2016, 07:33 PM
Same problem with my brothers '07. Plugs fixed it, then the cam phaser issue happened, and then engine shit the bed = new engine at 92,000km. My dad bought it off him and at 159,000 kms needed new plugs again. The issue started to show when going up long steep hills both times the plugs were in need of replacement.

longhorn
01-27-2016, 10:42 PM
Thanks guys

thecornbinderkid
01-29-2016, 10:00 AM
Its a bad coil

thecornbinderkid
01-29-2016, 10:01 AM
The coils go to shit on them I did mine every few years

longhorn
01-29-2016, 09:11 PM
How hard are the coils to change I just heard it was almost impossible to change the plugs?

96_z71
01-31-2016, 07:38 PM
Coils are dead simple to change. Test them first with an ohmeter to check the resistance. Pretty sure you just need an 8 mm socket to get em off. The plugs can be a bitch as ford had the genious idea of putting a 2 foot long spark plug in there that gets carboned up and they break. Lisle makes a really handy plug removal tool for these things though.

longhorn
02-01-2016, 10:14 PM
Neighbours 06 f150 had similar problems. Heavy hesitation, missfire, low power under load. Changed the plugs and it ran mint. Plugs had about 85k on them. Luckily none broke. Any codes? Cat might be plugged or something too.

Changed plugs and fuel filter today , it almost seems worse.
Checking Cat's tomorrow.
Can I take Cats right off and some how not have a Check Engine light on?

96_z71
02-01-2016, 10:58 PM
Removing the cats will most likely give you a CEL. Did you end up testing the coils?

longhorn
02-02-2016, 09:35 AM
mech just phoned he couldn't get 02 sensors out so he unbolted manifold and took it for a burn.
Went good so it sounds like CATS are plugged

longhorn
02-03-2016, 07:37 PM
Nothing $800 and 2 new CATs didn't cure.
Thanks all

Lurker
02-14-2016, 10:51 PM
That's good you got it fixed, I was thinking bad fuel pump.