PDA

View Full Version : 2002 Sierra, oil pressure sensor,


Happypants
07-26-2015, 10:41 PM
Picked up a 02 Sierra a few months back, had to do the knock sensors and oil pressure sensor, so I replaced the oil press sensor, and the gauge still didn't work, so I picked up another gauge cluster thinking Mabey it was the stepper motor behind the cluster, still did the same thing, while driving the oil pressure gauge drops to 0 and then the "oil pressure low" warning light comes on, anyone had this happen to them? Only thing I can think of is mabey a bad wire from the sensor out?

vajayjay
07-27-2015, 06:09 AM
Maybe the gauge works, you have no oil pressure :D

arjan
07-27-2015, 07:57 AM
Grounding issue? If multiple sensors fail, typically electrical ground is suspect.

Happypants
07-27-2015, 11:43 AM
Maybe the gauge works, you have no oil pressure :D



I auctually thought the same thing, I was gonna pop the pan off and check the screen on the oil pickup,

Happypants
07-27-2015, 11:45 AM
Grounding issue? If multiple sensors fail, typically electrical ground is suspect.



I think the truck was swamped in a mud hole at one time or another cuz when I pulled the intake off there was a inch of mud underneath it, I cleaned it all out and ordered all new pigtail harnesses for the knock sensors and rtv'd the rubber plugs into the intake to keep the moisture out, the old sensors were fucking gross, pretty much rotted apart

Burge
07-27-2015, 12:33 PM
i would put in a mechanical gauge, confirm you have oil pressure. then look into the harness.

i would do that before pulling then oil pan

Burge
07-27-2015, 12:34 PM
have you confirmed you where given the right sensor?

Happypants
07-27-2015, 03:06 PM
Yes I have, I double checked part numbers and it was identical to the sensor I took out


I'm gonna get a mechanical gauge and check it before I yank the pan

dirka dave
07-27-2015, 03:10 PM
I'm with burge.

Go with mechanical gauge.

4skin
07-27-2015, 08:51 PM
Does it have a fram filter on it ?