View Full Version : death wobble

08-05-2013, 02:20 PM
can any one help me out in finding the issues in the front end on my 86 sas'd toy pick up it only happin from 20-60 kms only when rut or bump in road 100 drives like a dream ill take pics tonight and post em im in the maple ridge area

08-05-2013, 05:21 PM
Check your trunion bearings,tie rods, wheelbearings, even the ubolts on the front, assuming its leaf sprung, could be anything, have someone sit in the truck and shimmy the steering wheel back and fourth and look for any movement of parts that could be worn out,

08-05-2013, 07:49 PM
Run with lower psi in your front tires

08-05-2013, 11:08 PM
how much caster does the rig have.

Punk in Drublic
08-05-2013, 11:10 PM
do 80 :dontknow:

Hello Kitty
08-05-2013, 11:47 PM
Linkage and no joke if your running tires that sat for a bit. Pitman arms always go.

08-19-2013, 06:36 PM
It was the leaf spring bushings on mine that were the culprit

08-19-2013, 09:02 PM
mine is sketchy, but the only time I get a death wobble is when the toe set is out. Cheap fix.

that's push pull, drop drag link, hammered bushings and 38.5 bias @ 3psi

08-19-2013, 10:28 PM

08-19-2013, 11:24 PM
almost sounds like all of the above will work........

to solve mine.... lower tire psi run 10-12 on street n slight toeout........
n i run grooved 36TSLs on beadlocks...

08-19-2013, 11:49 PM
i bought a trailer . worked for me

08-20-2013, 07:55 AM
What high steer are you running? I have a tg kit and within a year every tie rod end had bout 1/4" of slop in them. Garbage! Shoulda known better... Check those, could be your problem