PDA

View Full Version : death wobble


rs9000
08-05-2013, 03:20 PM
can any one help me out in finding the issues in the front end on my 86 sas'd toy pick up it only happin from 20-60 kms only when rut or bump in road 100 drives like a dream ill take pics tonight and post em im in the maple ridge area

Happypants
08-05-2013, 06:21 PM
Check your trunion bearings,tie rods, wheelbearings, even the ubolts on the front, assuming its leaf sprung, could be anything, have someone sit in the truck and shimmy the steering wheel back and fourth and look for any movement of parts that could be worn out,

hoser
08-05-2013, 08:49 PM
Run with lower psi in your front tires

Burge
08-06-2013, 12:08 AM
how much caster does the rig have.

Punk in Drublic
08-06-2013, 12:10 AM
do 80 :dontknow:

Hello Kitty
08-06-2013, 12:47 AM
Linkage and no joke if your running tires that sat for a bit. Pitman arms always go.

Redneck_04
08-19-2013, 07:36 PM
It was the leaf spring bushings on mine that were the culprit

TWOZEROFOUR
08-19-2013, 10:02 PM
mine is sketchy, but the only time I get a death wobble is when the toe set is out. Cheap fix.

that's push pull, drop drag link, hammered bushings and 38.5 bias @ 3psi

Trailjunkie
08-19-2013, 11:28 PM
https://fbcdn-sphotos-c-a.akamaihd.net/hphotos-ak-frc3/971014_395131967255596_1443536841_n.jpg

atoyot
08-20-2013, 12:24 AM
almost sounds like all of the above will work........

to solve mine.... lower tire psi run 10-12 on street n slight toeout........
n i run grooved 36TSLs on beadlocks...

Trailjunkie
08-20-2013, 12:49 AM
i bought a trailer . worked for me

BowlEEac
08-20-2013, 08:55 AM
What high steer are you running? I have a tg kit and within a year every tie rod end had bout 1/4" of slop in them. Garbage! Shoulda known better... Check those, could be your problem