PDA

View Full Version : 87 pickup restore


ktowner351
04-27-2012, 09:22 AM
Its been a long time comin, but it's just about there.. Tons of new goodies going in.. Pictures to come soon. The engine kit from engnbldr should be here by Monday and then let the process begin. Still need to find a way to soak my block and I need a valve grind done.. Installing a cb in the truck, did some custom dash work with the Cnc mill. Rebuilt my winch power box, still need to wire up a new plug.. All and all it's coming along nice.. Down the road I will need 2 fenders and a grill..

rogasm
04-27-2012, 11:37 AM
Pics or it's all a lie

ktowner351
04-27-2012, 12:25 PM
As soon as I get home from work lol

procircuit
04-27-2012, 01:47 PM
Never happened no pics.. Got all excited for a let down

Griswold
04-27-2012, 05:42 PM
Never happened no pics.. Got all excited for a let down

:s30x::dontknow:

Redneck_04
04-29-2012, 08:24 PM
i have a grill

ktowner351
04-30-2012, 11:42 AM
I got unbelievably drunk at a jack Daniels honey party I apologize :)
I'll try again this evening

procircuit
04-30-2012, 12:07 PM
FKN FAIL

dirka dave
04-30-2012, 04:21 PM
Need pictures.


Some of the jeep guys can't read so good.

ktowner351
05-01-2012, 12:09 AM
tada... its nothing special..:dontknow:

ktowner351
05-01-2012, 12:16 AM
out with emmissions crap, i swear its only a bush truck :P big old k&n and some go fast chrome, had to make an adapter for it at work but it should work good... some leather seats out of a newer 4 runner.. couldnt not have some browning crap in there and the camo i just couldnt turn down... cranks all nicely polished and the valves are cleaned up but as i mention they need a grind... shaved the head my self.. not finished the dash yet, all the checker plate is old and im changing it all to look like my cb mount.. some princess auto special high heat paint and some go fast red to make it look a little better lol and the reason im gettin some better leafs..

ktowner351
05-02-2012, 11:57 PM
engine kit arrived today, now to start buildy buildy...

dirka dave
05-03-2012, 06:59 AM
I like the red valve cover !!

Have fun with the rebuild.

ktowner351
09-24-2012, 09:07 PM
well the time finally came, the engine is in the truck and i turned it over for the first time today....


and it runs just not great...

its got oil preasure and its not leaking or anything.. it smokes quite a bit though and yes i understrand it should a little till the rings are set.. but at idle it sputters and drops 1500 it runs like a champ... i did the timing and that didnt help... i cheaped out and tried to run the old plugs cap and rotor cause they didnt look in that ruff of shape... gonna grab new shat tomorrow and try again... ill go back now and check the head tourque and valve spacing and change out the oil n filter too... when i pulled the plugs they were pretty black but not wet...

ktowner351
09-24-2012, 09:15 PM
also i did a whole ton of research on running emssionless.. so no more egr and limited vac lines....no leaks and yes the vac adavances are hooked up

ktowner351
09-24-2012, 11:11 PM
here is an update..

Griswold
09-25-2012, 09:01 AM
Nice work so far

procircuit
09-25-2012, 09:12 AM
that looks minty!!!.. id think about moving those gauges off the top of the dash like that.. they will drive you nuts.. nice progress so far!

atoyot
09-25-2012, 10:19 AM
bringin her back to life....nice!

youngun
09-25-2012, 11:01 AM
Running for the toy run?

Looks good

ktowner351
09-25-2012, 02:05 PM
I'm aiming for it I still need to string some cash together for those leafs

youngun
09-25-2012, 02:47 PM
ya man, hopefully i still got em. I moved stuff around and donno where alot of stuff went now

ktowner351
09-25-2012, 07:17 PM
new plugs, cap, and rotor done... still not running so great... cant seem to find any vacuum leaks but when i remove the lines on the distributor nothing changes.... if i unplug a line off the bottom of the intake then it revs up like it should.... I'm confused???? new fuel filter in, head bolts are checked and the valves are double checked.... i guess ill check float level next??

ktowner351
09-25-2012, 09:16 PM
maybe even good the carb a good cleaning out... maybe it got gunk in it from sitting so long

lincoln locked
09-26-2012, 10:51 AM
looking good

glopedawg
09-26-2012, 06:27 PM
That re done engine looks like a LC engineering 22RE block all pollished like that with he red too. Cool truck man, it should be a fun one.

SHITTY
09-26-2012, 09:26 PM
like the engine hoist.[36] what carb are you using? looking good

ktowner351
09-26-2012, 10:24 PM
just a stock carb but it isnt the original one i ended up buying a new one like 6 years back.... if i only i knew what i was getting i would have got a weber for the outrageous price.....

ktowner351
09-30-2012, 11:56 PM
carb off and cleaned all out... was a little junk in there and the float was out to lunch... adjusted the floats and it fired right up... almost have it dialed just need to lower the level of the float a little and it should be prime!!! next is to wait on the bolts to come for fastenal for my leaf springs.... got some corner marker lights and grill installed thanks to youngun

ktowner351
09-30-2012, 11:57 PM
anyone know some stock adjustments for the carb screws... i think there is just the 2 the hot idle and the other one...

85chevy
10-01-2012, 07:17 PM
Hahaha nice tractor[cheers]

ktowner351
10-13-2012, 12:16 AM
insurance is on and it successfully got me to work everyday this week.... still need to tweak the carb its running way rich... little trouble with my alternator dummy light wire trying to get the resistance correct... and last but not least , the little crank case breather that goes just behind the oil fill cap.. what are my options on that or am i stuck with the 30$ k&n 2" filter