PDA

View Full Version : Brake problem


godtool
01-29-2012, 09:11 PM
Rear brake line came off my 83 plow truck and now it does no want tobleed properly and brake light is on. I'm thinking it has something to do with that valve on front frame rail... I bench bled master cyinder and bled brakes yet rear brakes still not working right and red brake light still on dash.... and I cant find my haynes manual to trouble shoot it. Any help woud be appreciated....

tchevy
01-29-2012, 09:32 PM
bleed it good, then start it... then press the brake pedal down with everything u got.. shouldnt center the porp valve

4skin
01-29-2012, 10:24 PM
x2 stomp the brakes hard
or you might have to undo a front bleeder and press brakes until it clicks over
need 2 peeps to do it
also some models you need to pull the light switch out of proportining valve
for it to recenter

kootenaycat
01-30-2012, 09:45 PM
If slowly pressing the pedal down doesn't work your gonna have to give it a couple quick jabs to get it to pop back to centre then gravity bleed it til you have a decent flow. Then bleed it normally, just don't press real hard on the pedal otherwise it might pop the proportioning valve back over again.

godtool
01-31-2012, 08:59 AM
Thanks. I'll see what happens.

godtool
02-13-2012, 10:31 AM
Tried the jab method no luck. Tried taking out switch but could not get a wrench to fit. I have a unit I took out of a 1974 gmc truck and its exactly 5/8" yet this one on my 83 no wrench fits. Is it a special size... like I called lordco and they were dumfounded. Buddy said nut could be rusty and just to pound a wrench on but that aint going to work... I have yet to try bleeding a front calliper. Found my Haynes Manual They call it the RAWL sensor and said take it to a garage! lol.