PDA

View Full Version : PART TIME light


Hellboy
01-07-2012, 03:10 PM
So.... I went and fixed my Transfer Case linkage with some washers and bigger screws... It worked and I can shift into everything... 2HI 4HI 4LO... But now my stupid PART TIME light on the dash won't go off... I know it's in 2 wheel cause I can one-tire-fire my wet driveway...

I'm going to be googling this issue... but anyone with an idea is always welcome to post :P

Hell even if you don't have an idea feel free :dontknow:

bcmaxx
01-07-2012, 03:14 PM
did you re adjust the linkage after fixing it? the switch is on the t-case for the light

Hellboy
01-07-2012, 03:26 PM
did you re adjust the linkage after fixing it? the switch is on the t-case for the light

Didn't readjust anything just stuck the rod back in the hole and put spacers behind the hole so it'd stop falling out... didn't know you had to readjust anything...

Okay I realize that didn't make much sense so I'll just get a pic of what was wrong and how I fixed it...


Before:

(the circled rod was falling out of circled bracket....
http://i1222.photobucket.com/albums/dd496/93pathy/Shifterlinkage.jpg

After:

I put a stack of washers behind the bracket (which I painted red) and got longer screws....
http://a7.sphotos.ak.fbcdn.net/hphotos-ak-snc7/387448_246457895425285_100001832302217_625900_4180 96814_n.jpg

bcmaxx
01-07-2012, 03:51 PM
theres an adjuster screw in your first pic, 13mm head on the rod to the left of the blue circle. You make the adjustment in 4l0

1. Shift transfer case into 4 Lo position.

2. Loosen lock nut on adjusting trunnion (This is on the shift rod attached to the Transfer Case Shift Lever Assembly).

3. Verify that linkage rod slides freely in trunnion.

4. Verify that Transfer Case range lever is fully engaged in 4 Lo position.

5. Tighten adjusting trunnion lock bolt.

6. Verify proper shift operation.

Be sure check fluid level first.

Hellboy
01-07-2012, 04:12 PM
Thanks for the info man.. Ill check into that next week i've run outta time on the weekend...

vajayjay
01-07-2012, 07:11 PM
My light just started working about two months ago :D

Hellboy
01-08-2012, 12:30 AM
My light just started working about two months ago :D

Ya i realize that the light isnt really needed as long as you know what gear your in, and you know it works... Its just one of those things that'll bug me for a few days until i just unplug the damn light lmao