PDA

View Full Version : 4.0L missing


Hellboy
12-04-2011, 10:56 PM
So my Aunts 4.0L cherokee is misfiring and she wants me to come check it out. Anyhow I'm hoping it's simple stuff like a bad plug or shitty cap. However, if its not the regular stuff (plugs cap rotor wires), just wondering what else it could be if anything?

Thought I'd put that out there since I have to go out there after work tomorrow as she doesn't have a car now.

Its a newer one 96 or higher And automatic

[cheers]

crazylike
12-04-2011, 11:07 PM
plugs , wires , coil , fuel filter , vacuum leaks , incorrect idle , incorrect ignition timing , low or uneven cylinder compression , choke , clogged or dirty injector , cracked distributor , leaky egr valve. these are what the books says for engine misses

Hellboy
12-04-2011, 11:10 PM
Ya i wish i had a compression tester cuz thats easy too...

Happypants
12-05-2011, 06:38 PM
Check the main stuff first, cap,rotor,plugs,wires, if there is any yellow corrosion on the points or anything they need to e
Replaced, also check the top of the cap, it could be
Cracked or possibly melted, I've melted a cap before, if that's all good it could be a fuel filter or a number of other things, CPS,TPS,iac, doubt it's inside the motor, most likely a sensor

Hellboy
12-05-2011, 10:07 PM
Check the main stuff first, cap,rotor,plugs,wires, if there is any yellow corrosion on the points or anything they need to e
Replaced, also check the top of the cap, it could be
Cracked or possibly melted, I've melted a cap before, if that's all good it could be a fuel filter or a number of other things, CPS,TPS,iac, doubt it's inside the motor, most likely a sensor

ok so its a 2001 and theres definately no cap or rotor. plugs are brand new.

Only fuel filter on a 2001 cherokee is in the gas tank according to crappy tire, and I couldn't see one in the open anywhere...

I think it might be the thing your truck was doing nick, cause I drove it a bit and it would run fine... then engine light would flash and it would stutter and surge, almost like it would die... I had to pop into neutral and rev it, then back to drive...

B
12-05-2011, 10:16 PM
If the engine light triggered u have a stored code scan and repair or keep guessing and replacing needlessly

Hellboy
12-05-2011, 10:25 PM
If the engine light triggered u have a stored code scan and repair or keep guessing and replacing needlessly

scanned and it said 'cylinder misfired'

reset the comp and 2 weeks later it did it again...

now its running rough

and we havent replaced anything yet...

crazylike
12-06-2011, 08:54 AM
i would venture a guess and say bad/plugged injector or burned out plug on cylinder 2..

Hellboy
12-06-2011, 11:17 AM
i would venture a guess and say bad/plugged injector or burned out plug on cylinder 2..

Why cylinder 2..?

crazylike
12-06-2011, 11:42 AM
i had a 4.0 and i had many issues similar to this and it was the number 2 injector multiple times. just thinking since it sounds so much the same you might wanna try looking there first. i just noticed you said new plugs have been installed so i would say injector or maybe even the coil.

Hellboy
12-13-2011, 02:15 AM
i had a 4.0 and i had many issues similar to this and it was the number 2 injector multiple times. just thinking since it sounds so much the same you might wanna try looking there first. i just noticed you said new plugs have been installed so i would say injector or maybe even the coil.

so guess what...

it was the number 2 injector

coincidence i guess :dontknow:

crazylike
12-13-2011, 09:27 AM
holy shit i'm good lol :)

BleepinJeep
12-13-2011, 02:54 PM
Nice work (stands and gives applause)

Hellboy
12-13-2011, 03:34 PM
Nice work (stands and gives applause)

http://www.myemoticons.com/images/entertainment/stage-/take-a-bow.gif