PDA

View Full Version : 3.0 sr5 no fuel


Deggs
06-13-2011, 11:45 AM
I have an 88 4runner getting no fuel.

Ive checked fuses and relays, including the circuit open relay under the dash.

I've got power to the pump on cranking, but of course no power outside of that as the motor isn't running.

I'll be checking the AFM today both physical function and pin outs.

I'm about to pull and replace the pump...

The truck sat for a couple + years with the PO.


Anything I've missed? Any tricks?

Thanks,

D.

crazylike
06-13-2011, 12:25 PM
did you check your fuel filter? any of the fuel lines leaking? damaged?

Barndog
06-13-2011, 12:36 PM
you should be able to hear the fuel pump as soon as the key is on the run position , from what you describe it is the fuel pump , the is an access panel to the tank top inside passanger department , hope this helps[cheers]

Deggs
06-13-2011, 12:37 PM
Ya, new filter and tried running fuel up the line with it out. Gonna hit the pump direct today too.

youngun
06-13-2011, 01:03 PM
you should be able to hear the fuel pump as soon as the key is on the run position , from what you describe it is the fuel pump , the is an access panel to the tank top inside passanger department , hope this helps[cheers]


Not on a toyota, the fuel pump doesn't turn on till you are cranking it over. Atleast thats how all mine are wired

Deggs
06-13-2011, 01:46 PM
I just put 12 to the pump directly and listened from the hatch, no love.

Anyone got a pump for an 88 v6?

youngun
06-13-2011, 02:22 PM
I do but im in kelowna

Griswold
06-13-2011, 03:09 PM
I gots 2....one is still in the 94 I'm partin out.....Check see if that year will work for you.......if so just give me a shout Dave.

Deggs
06-13-2011, 03:28 PM
85-91 fits

Reeseman
06-27-2011, 03:49 PM
a pump should turn on when you first turn on the key to prime the system. put 12 volts to the pump and you should here it turn on. sounds like a pump