View Full Version : Engine vibe

04-11-2011, 08:06 PM
On my way back to alberta today, goin back to work after having the last 10 days off, and as I was driving down the hi-way near golden, the engine started to vibrate and it was getting worse.
Pull into the petro can and find that my harmonic balancer let go, no rubber left and the weight was just free floating. So now I'm sitting in the timmies waiting for the wife to drive from summerland with a trailer, to load the truck and drag it to the shop I work at so I can fix it there where all my tools are. So if there's any fibc members in golden who want to bs and have some coffee, ill be at the timmies for the next 5 hrs untill the wife shows up. Will get pics up tomorrow.

04-13-2011, 09:41 PM
http://a8.sphotos.ak.fbcdn.net/hphotos-ak-snc6/216255_10150547091565434_610295433_18363850_647825 6_n.jpg
http://a2.sphotos.ak.fbcdn.net/hphotos-ak-ash4/205143_10150547091955434_610295433_18363851_550195 5_n.jpg

04-13-2011, 09:49 PM
damn that had to suck hope you got it picked up and fixed atleast you weren't in the middle of nowhere ( well i tell my son that golden is kinda in the middle of nowhere since he moved there a couple yrs ago lol)

04-13-2011, 10:07 PM
shit buddy that sucks.

04-14-2011, 07:06 PM
Ouch not kewl at all

04-14-2011, 07:10 PM
Ya, it wont be fixed for a little while, money is tight after the last few weeks, trailered a parts truck home then renting another to haul the bronco. Luckily I didnt drive the bronco for to long once it let go, it was starting to hit the bottom of the water pump and timing cover, bunch of small aluminum shavings everywhere. Read some horror storries to over on fullsize bronco to about guys having their cranks split on the high milage engines from the severe in-balance.

04-14-2011, 08:29 PM
Wow, that sucks. Similar thing happens often on suzuki engines. Sucks for sure