PDA

View Full Version : Xj problems,


Happypants
01-25-2011, 04:36 PM
My new 95 xj is having a few problems, first is it won't start in park, but starts in neutral-I think that is the neutral safety switch,


Second is it just randomly turns off, don't know why but it will run for 20 or 30 min then it just shuts off,


Anyone gotta guess?

'Balmer
01-25-2011, 04:58 PM
:confused0006: Hate to say it...














































it's a Jeep! :dontknow: :D

'Balmer
01-25-2011, 05:02 PM
But seriously now, I'm thinking it may be ignition related. Seems to me I remember issues like that were an ignition component (ignitor or that ceramic thingy that I forget the name of (usually found on the fire wall or inner fender - 1 wire in, 1 wire out) heated up after a while of running and then seemed to stop conducting. Just an idea?

crazylike
01-25-2011, 05:08 PM
nss switch sounds right to nuetral starting issue.

as for stalling issue the book says

1 idle speed incorrect

2 fuel filter clogged and or water impurities in the fuel system

3 choke not operating properly

4 damaged or wet distibutor cap and or wires

5 faulty emissions components

6 faulty or mis gapped plugs

7 vacuum leak at the carburator/intake manifold or vacuum hoses.

4skin
01-25-2011, 05:16 PM
its yours thats its first problem bud
not sure if those have the ballast resistor balmer talks about if it does
try changing it

Trailjunkie
01-25-2011, 05:41 PM
But seriously now, I'm thinking it may be ignition related. Seems to me I remember issues like that were an ignition component (ignitor or that ceramic thingy that I forget the name of (usually found on the fire wall or inner fender - 1 wire in, 1 wire out) heated up after a while of running and then seemed to stop conducting. Just an idea?
what he said

Chopstick
01-25-2011, 05:41 PM
My new 95 xj is having a few problems, first is it won't start in park, but starts in neutral-I think that is the neutral safety switch,
Second is it just randomly turns off, don't know why but it will run for 20 or 30 min then it just shuts off,
Anyone gotta guess?

by pass the switch all together so you dont have to worry about it or are you keeping the auto (me no remember)

Chopstick
01-25-2011, 05:43 PM
But seriously now, I'm thinking it may be ignition related. Seems to me I remember issues like that were an ignition component (ignitor or that ceramic thingy that I forget the name of (usually found on the fire wall or inner fender - 1 wire in, 1 wire out) heated up after a while of running and then seemed to stop conducting. Just an idea?

95s dont have that,

Happypants
01-25-2011, 08:41 PM
My new 95 xj is having a few problems, first is it won't start in park, but starts in neutral-I think that is the neutral safety switch,
Second is it just randomly turns off, don't know why but it will run for 20 or 30 min then it just shuts off,
Anyone gotta guess?

by pass the switch all together so you dont have to worry about it or are you keeping the auto (me no remember)

if you want help tomorrow i can come out after work and help diagnose the problem with you :dontknow:



Sure, me and Jess will be putting the rear back together with new leafs and shit and pulling the t-case to put the sye in if u wanna come out and tinker with it, anytime after 5 will be cool,

Chopstick
01-26-2011, 05:53 AM
alright, i'll text ya later

old codger
01-26-2011, 06:27 AM
JOIN ELECTRICAL EXPERTS PLEASE !!!!:confused0006: :confused0006: :confused0006: :)

85chevy
01-26-2011, 09:19 AM
Does it start back up again right away or does it have to sit for a bit before u can start it again?

4skin
01-26-2011, 09:35 AM
nick have you been welding on it with battery hooked up ??
if you have possibly fried ecu

bcmaxx
01-26-2011, 09:41 AM
Crank position sensor will start acting like that before it goes. next time unplug it and plug it back in and see if it restarts right away

J20
01-26-2011, 09:50 AM
3 choke not operating properly
7 vacuum leak at the carburator/intake manifold or vacuum hoses.

dude its injected......

NSS and crank sensor nick.........not sure if my 91 is the same but i have a spare(new) crank sensor i carry when wheelin you can try it if ya want

crazylike
01-26-2011, 10:20 AM
just posted what the book had listed for why it would stall. the book cover from 84-2000 so some shit obviously won't apply. personally i was leaning towards number 2 fuel filter/system

Chopstick
01-26-2011, 11:42 AM
dude its injected......

NSS and crank sensor nick.........not sure if my 91 is the same but i have a spare(new) crank sensor i carry when wheelin you can try it if ya want

91 are the same,

Happypants
01-26-2011, 04:07 PM
Does it start back up again right away or does it have to sit for a bit before u can start it again?

Starts right back up


JOIN ELECTRICAL EXPERTS PLEASE !!!!:confused0006: :confused0006: :confused0006: :)


YOU! never have any fucking input on anything so fuck OFF!

And Bruce,,

No I've never welded on the truck with the battery connected, everytime I do weld I yank the battery right out just to be sure,

Happypants
01-26-2011, 04:08 PM
just posted what the book had listed for why it would stall. the book cover from 84-2000 so some shit obviously won't apply. personally i was leaning towards number 2 fuel filter/system

I'm gonna do the fuel filter soon but it's a ways down the list, I wanna get it lifted first so I can fit under it :D

old codger
01-27-2011, 12:19 PM
Starts right back up





YOU! never have any fucking input on anything so fuck OFF!

And Bruce,,

No I've never welded on the truck with the battery connected, everytime I do weld I yank the battery right out just to be sure,

I'VE probaly been retired longer than you've owned a 4x4, so any info that I might have is out dated by now! so I think it's best if I don't comment on
mechanical stuff!!!. My 4x4ing started in 1954 in Airfeild Construction with the R A F in England!.

Moondog
01-27-2011, 12:37 PM
I'VE probaly been retired longer than you've owned a 4x4, so any info that I might have is out dated by now! so I think it's best if I don't comment on
mechanical stuff!!!. My 4x4ing started in 1954 in Airfeild Construction with the R A F in England!.


:gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives:

Salty enough for you [22]

Happypants
01-27-2011, 12:55 PM
^^^^^^^^^^^^^^^^^^^^^^^^ like moondog said, :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives: :gives:

im not here looking for advise on the first world war, im looking for advise why my jeeps doing what its doing, i dont fucking care how long you have "owned a 4x4" so piss off if you got nothing but bullshit to say go fuck yourself









I'VE probaly been retired longer than you've owned a 4x4, so any info that I might have is out dated by now! so I think it's best if I don't comment on
mechanical stuff!!!. My 4x4ing started in 1954 in Airfeild Construction with the R A F in England!.

'Balmer
01-27-2011, 02:23 PM
Do you have this thing sorted out yet Nick? ... you ol' salt you.

Happypants
01-27-2011, 02:32 PM
Not yet, been putting my lift in my jeep

'Balmer
01-27-2011, 02:34 PM
The long arm from your old rig?

85chevy
01-27-2011, 05:14 PM
I would think first check the fuel pump and filter when it shuts off is it stumbling or kinda like the key was turned off only u didn't do it?

Happypants
01-27-2011, 06:13 PM
Ya Balmer, the old long arms and what not, an 85chev, ya it just turns off when it's sitting, like I took it to stave for the toy run and it didn't do it once, only like when it's sitting there idling,

tchevy
01-27-2011, 06:52 PM
sorry to say nick but you got alot of useless info on this thread. people who dont know shouldnt bother, just sending you on a goose chase. nss circuit is a problem, prob the switch. the dying like that is a heat related issue if it happens after 30 min or so. so something electronic is breaking down. possibly the cranks sensor at back of block, or pickup coil etc. i assume this is a 4.0 lol. you will get her figured out.[cheers]

Happypants
01-27-2011, 07:27 PM
Ya, I'm sure I will have it figured out, just looking for some/any ideas on what it might be

poostang
02-01-2011, 02:30 PM
try swapping coilpack i heard of them gettting hot and just cutting out ..
also on the fender drivers i do believe theres a ballist there toss a new 1 on if that shorts out i know it will cut the pump out

also check fuel pump sending unit check the 2 hard lines coming out...i saw this a month ago what happend was 1 cracked and gave it play so pump was moving in tank and actually sucking and getting stuck in tank and it caused the dieing out issue.....

just some ideas anyways

youngun
02-01-2011, 04:57 PM
burn it :dontknow:

hoser
02-01-2011, 05:13 PM
well ive been 4x4ing for years now probably longer than you have been alive ..been retired for awhile also and i think it might have something to do with muffler..:confused0006: