PDA

View Full Version : Help!! cherokee stoped running won't start???


Legend
01-10-2011, 04:20 PM
So I was pushing some small trees over and one of them broke off a bit tall. I had to reverse and it jamed up between my oil pan and frame and pushed into the back of the alternator. Instantly the truck shut off and wouldn't start, after inspection and finding the tree under there, I quite easly removed it by hand. I can't see any damage to anything really other then the wood that pushed into the alternator. So I'm a bit confused as to why it won't run? Even if the alternator was done shouldn't it run off the battery?? Do jeeps require the altertnator to be working to run even with a good battery? Is the coil powered directly from the alt? Idunno I'm just throwin out ideas, any help would be appreciated thanks. Oh and its a 94 cherokee 4 liter.

rmiller026
01-10-2011, 04:27 PM
Any knocked off wires?

crazylike
01-10-2011, 04:28 PM
did you by chance blow up a inline fuse or maybe wiring on the tranny NSS switch. not sure if there an inertia switch or not? few ideas for yeah to try

B
01-10-2011, 04:31 PM
quick call national ....


hahahhahhhahahahha ...

B
01-10-2011, 04:37 PM
sorry couldn't resist [22]

gimmie a call if ya can't figure it out kyle ...

604 465 5559

Legend
01-10-2011, 04:40 PM
Lol fml, it still cranks over, just checked for spark got nothing, I'm gonna try running power to the coil

Legend
01-10-2011, 04:40 PM
Oh and this is live feed from stave lol

crazylike
01-10-2011, 04:43 PM
looking the book it says turns over but no start things to check
1 fuel tank empty?
2 battery gone bad slow turning motor?
3 battery terminal connection loose?
4 fuel not reaching carb or injectors fuel line damaged or fuel pump failer?
5 choke not operating
6 faulty distibutor components
7 low compression
8 valves issues
9 water in fuel
10 defective or damaged ignition coil
11 dirty damaged injectors or carb
12 wet or damaged ignition components
13 bad plugs
14 broken loose or disconnected wires in starting circut
15 loose distributor
16 broken loose ordisconnected wires at the ignition coil or faulty coil
17 timing chain failer

Legend
01-10-2011, 04:54 PM
Woo thanks guys, I blew the engine control fuse, I'm up the trail by the boat launch that goes to the power line, good thing ill be driving out.

rmiller026
01-10-2011, 05:07 PM
Shit yo u coulda said u were stranded I woulda come helped out

crazylike
01-10-2011, 05:16 PM
good to here

Legend
01-10-2011, 06:03 PM
thanks for all the quick replies

Griswold
01-10-2011, 06:44 PM
Is the Engine light on.........................

dirka dave
01-10-2011, 07:04 PM
Is it snowing ?


Pick me up a case of beer on your way home..... I'll pay you next tuesday.