PDA

View Full Version : Truck Shutters When Engaging clutch


gowen
03-01-2010, 10:59 AM
Finding that my 92 Dodge W250 4x4 (non hub) will shutter when starting out. This is progressively getting worse, requiring a very gentle engagement of the clutch in second or starting out in first gear. My truck has a five speed with OD. This seems to get worse as I drive it during the day. Just wondering if it possibly has a rear engine seal leaking oil on to the clutch somehow, making it progressive.

Or maybe it has a problem with the transmission and or engine mounts. Or maybe the clutch is just due for replacement, although it still feels good and doesn't slip. The vehicle has 209,000 km, I purchased it at 137,000 from the BC Forest Service so i suspect it is still the original clutch.

Anyone elxe experienced this or suggestions on the proper fix. Thanks

Gowen
[cheers]

crazylike
03-01-2010, 11:16 AM
sounds like someone at bc forest liked to ride the clutch i would recommend you take a look throught the inspection hole and look for a burned clutch pad and or a polished spot on the clutch plate...

'Balmer
03-01-2010, 11:49 AM
yup... sounds like a burned/warped clutch to me.

barracuda
03-01-2010, 12:37 PM
transmountcan be shot andit willshudder

Maelthra
03-01-2010, 01:31 PM
I had the same thing, it was a toasted clutch and a burnt flywheel.

4skin
03-02-2010, 12:29 AM
all of the above if its mecanical linkage check for wear in pivot points

gowen
03-04-2010, 01:40 PM
Thanks for the replies guys. Can a burnt flywheel be reconditioned (machined) or should I be looking for a replacement?

4skin
03-04-2010, 07:43 PM
[cheers] machine flywheel new disk presureplate and throw out bearing[36]

mus-Tard
03-04-2010, 10:02 PM
not too long ago l instaled a new clutch in a car and that was the case.
band fucking new clutch. and shuttered when letting the peddel out.
was bad dampening springs.