PDA

View Full Version : 88 cherokee INJECTORS NOT FIREING


deer laredo
11-09-2009, 03:47 PM
I was driving my cherokee and it died on me. lots of fuel getting to the fuel rail lots of spark. the injectors are not squirting... Ive tried a new computer and cps crank position sensor... still no go... anybody have any suggestions???

Justin_B
11-09-2009, 06:59 PM
Try new injectors??:confused0006:

Trooper
11-09-2009, 08:14 PM
Fusable link? Did one of your injector wires ground out on something?

The odds of all your injectors failing at the same time and needing new injectors is very very low.

tchevy
11-09-2009, 09:36 PM
He means injector pulse

nbrowser
11-09-2009, 09:49 PM
Doncha just love the Renix injection system....I know I got it on my Heep as well, you say you have pressure at the rail, spark to the cylinders but no injector pulse...typically they are ground fired from the ECU but get power from a relay or fusible link...I'd start checking the wiring for the injectors (power side) to see if anything is broken or defective on that side.

Happypants
11-09-2009, 09:52 PM
fuseable link is toast, nuff said, i dont remember where it is but a haynes manual will tell ya, i was just looking in one a hour or so ago

deer laredo
11-09-2009, 10:48 PM
No power at the injectors what so ever... Any body know where the fusable link is or relay if there even is one. Looked in haynes repair manual, mabe not hard enough.

deer laredo
11-12-2009, 02:21 PM
Problem solved... Shitty wire must of shorted out somewhere just ran a new one...